ነፃ የHTTP Status Codes ማጣቀሻ
ለሁሉም HTTP status codes ሊፈለግ የሚችል ማጣቀሻ — እያንዳንዱ ምን ማለት እንደሆነ፣ መቼ እንደሚጠቀም እና የተለመዱ ምክንያቶች። ከ100 እስከ 511።
61 የሁኔታ ኮዶች
100ቀጥል
አገልጋዩ የጥያቄውን ራስጌዎች ተቀብሏል፣ ደንበኛው ከአካሉ ጋር መቀጠል አለበት።
ቀጥል
አገልጋዩ የጥያቄውን ራስጌዎች ተቀብሏል፣ ደንበኛው ከአካሉ ጋር መቀጠል አለበት።
ለExpect: 100-continue ጥያቄዎች ጥቅም ላይ ይውላል። አገልጋዩ ደንበኛው ከመላኩ በፊት አካሉን ለመቀበል ፈቃደኛ መሆኑን ያረጋግጣል። በዘመናዊ ድረ-ገጾች ላይ አልፎ አልፎ ይታያል።
101ፕሮቶኮሎችን መቀየር
አገልጋዩ በደንበኛው ጥያቄ መሠረት ፕሮቶኮሎችን እየቀየረ ነው።
ፕሮቶኮሎችን መቀየር
አገልጋዩ በደንበኛው ጥያቄ መሠረት ፕሮቶኮሎችን እየቀየረ ነው።
በጣም በተለምዶ ለWebSocket ማሻሻያዎች ጥቅም ላይ ይውላል — ደንበኛው Upgrade: websocket ይጠይቃል፣ አገልጋዩ ደግሞ ለመቀየር 101 ምላሽ ይሰጣል።
102በማስኬድ ላይ
አገልጋዩ ጥያቄውን ተቀብሎ እያሠራ ነው፣ ግን እስካሁን ምላሽ አልተገኘም።
በማስኬድ ላይ
አገልጋዩ ጥያቄውን ተቀብሎ እያሠራ ነው፣ ግን እስካሁን ምላሽ አልተገኘም።
ረጅም ስራዎችን በሚያከናውንበት ጊዜ የደንበኛ ጊዜ ማለቅን ለመከላከል የሚላክ የWebDAV ጊዜያዊ ምላሽ። ጊዜ ያለፈበት — ዘመናዊ አገልጋዮች መላክ የለባቸውም።
103ቀደምት ፍንጮች
ከመጨረሻው ምላሽ በፊት የሚላኩ የመጀመሪያ ራስጌዎች።
ቀደምት ፍንጮች
ከመጨረሻው ምላሽ በፊት የሚላኩ የመጀመሪያ ራስጌዎች።
የመጨረሻው ምላሽ በሚዘጋጅበት ጊዜ አገልጋዮች የLink ራስጌዎችን (preload/preconnect) እንዲልኩ ያስችላል፣ ስለዚህ አሳሾች ወሳኝ ንብረቶችን ቀድመው ማምጣት ይጀምራሉ።
200እሺ
ጥያቄው ተሳክቷል።
እሺ
ጥያቄው ተሳክቷል።
መደበኛው የስኬት ምላሽ። ትርጉሙ በHTTP ዘዴው ይወሰናል፦ GET → ንብረት ተመልሷል፣ POST/PUT → ተግባር ተጠናቅቋል።
201ተፈጠረ
አዲስ ንብረት በተሳካ ሁኔታ ተፈጥሯል።
ተፈጠረ
አዲስ ንብረት በተሳካ ሁኔታ ተፈጥሯል።
ከPOST በኋላ የተለመደ። ምላሹ ወደ አዲሱ ንብረት URL የሚያመለክት Location ራስጌ ማካተት አለበት።
202ተቀባይነት አግኝቷል
ጥያቄው ለሂደት ተቀባይነት አግኝቷል፣ ነገር ግን ሂደቱ አልተጠናቀቀም።
ተቀባይነት አግኝቷል
ጥያቄው ለሂደት ተቀባይነት አግኝቷል፣ ነገር ግን ሂደቱ አልተጠናቀቀም።
ለአሲንክ ስራዎች — አገልጋዩ ስራውን በተራ እያስቀመጠ ነው። ደንበኛው የሁኔታ endpoint መጠየቅ ወይም በኋላ መመልከት አለበት።
203ኦፊሴላዊ ያልሆነ መረጃ
ምላሹ በተለወጠ ፕሮክሲ ተስተካክሏል።
ኦፊሴላዊ ያልሆነ መረጃ
ምላሹ በተለወጠ ፕሮክሲ ተስተካክሏል።
ጥያቄው ተሳክቷል፣ ነገር ግን አማካይ (እንደ ማከማቻ ወይም ተለዋጭ ፕሮክሲ ያለ) ከመነሻ አገልጋዩ የተላለፈውን ይዘት ቀይሯል — ለምሳሌ ምስሎችን እንደገና በመጨመቅ። በተግባር ብርቅ ነው።
204ይዘት የለም
ጥያቄው ተሳክቷል ግን የምላሽ አካል የለም።
ይዘት የለም
ጥያቄው ተሳክቷል ግን የምላሽ አካል የለም።
ብዙውን ጊዜ ለDELETE ስራዎች ወይም አካል መመለስ ለማያስፈልጋቸው PUT ማዘመኛዎች ጥቅም ላይ ይውላል። ደንበኛው ከአሁኑ ገጽ መውጣት የለበትም።
205ይዘት ዳግም አስጀምር
ጥያቄው ተሳክቷል፤ ደንበኛው የሰነድ እይታውን ዳግም ማስጀመር አለበት።
ይዘት ዳግም አስጀምር
ጥያቄው ተሳክቷል፤ ደንበኛው የሰነድ እይታውን ዳግም ማስጀመር አለበት።
እንደ 204፣ ምንም አካል አይመለስም — ግን ደንበኛው ጥያቄውን ያመነጨውን ቅጽ ወይም እይታ ዳግም እንዲያስጀምር ተጨማሪ ትዕዛዝ ይደርሰዋል (ለምሳሌ ለቀጣዩ ግቤት የቅጽ መስኮችን ማጽዳት)።
206ከፊል ይዘት
አገልጋዩ የንብረቱን ከፊል ብቻ አድርሷል።
ከፊል ይዘት
አገልጋዩ የንብረቱን ከፊል ብቻ አድርሷል።
ለRange ጥያቄ ምላሽ። በተቋረጡ ውርዶች ለመቀጠል ወይም ትላልቅ ፋይሎችን ለማጓጓዝ በቪዲዮ ማጫወቻዎችና በውርድ አስተዳዳሪዎች ጥቅም ላይ ይውላል።
207ባለብዙ-ሁኔታ
የምላሹ አካል ለበርካታ ስራዎች በርካታ የሁኔታ ኮዶችን ይይዛል።
ባለብዙ-ሁኔታ
የምላሹ አካል ለበርካታ ስራዎች በርካታ የሁኔታ ኮዶችን ይይዛል።
WebDAV፦ አንድ XML አካል የበርካታ ንዑስ-ስራዎችን ውጤት በተናጠል ያሳውቃል — ለምሳሌ አንዳንድ ንጥሎች የተሳኩበት እና ሌሎች ያልተሳኩበት የጅምላ ማዛወሪያ።
208አስቀድሞ ተዘግቧል
የስብስቡ አባላት ቀደም ሲል በምላሹ ውስጥ ተዘርዝረዋል።
አስቀድሞ ተዘግቧል
የስብስቡ አባላት ቀደም ሲል በምላሹ ውስጥ ተዘርዝረዋል።
WebDAV፦ ትስስሮች ዙር ሲፈጥሩ አንድ ስብስብ አባላትን ደጋግሞ ላለመዘርዘር በ207 Multi-Status ምላሾች ውስጥ ጥቅም ላይ ይውላል።
226IM ጥቅም ላይ ውሏል
ምላሹ በምንጩ ላይ ከተተገበሩ የምሳሌ ማስተካከያዎች የተገኘ ነው።
IM ጥቅም ላይ ውሏል
ምላሹ በምንጩ ላይ ከተተገበሩ የምሳሌ ማስተካከያዎች የተገኘ ነው።
ዴልታ ኢንኮዲንግ፦ ባንድዊድዝ ለመቆጠብ አገልጋዩ ሙሉ ምንጩን ፋንታ ከቀድሞው ስሪት ጋር ያለውን ልዩነት ይመልሳል። እምብዛም ተግባራዊ አይደረግም።
300በርካታ ምርጫዎች
ከምንጩ በርካታ ውክልናዎች ይገኛሉ።
በርካታ ምርጫዎች
ከምንጩ በርካታ ውክልናዎች ይገኛሉ።
አገልጋዩ በርካታ አማራጮችን (ለምሳሌ የተለያዩ ቅርጸቶች ወይም ቋንቋዎች) ያቀርባል እና ደንበኛው አንዱን መምረጥ አለበት። ራስ-ሰር የይዘት ድርድር ብዙውን ጊዜ ይህን ስለሚያከናውን እምብዛም ጥቅም ላይ አይውልም።
301በቋሚነት ተዛውሯል
ምንጩ በቋሚነት ወደ አዲስ URL ተዛውሯል።
በቋሚነት ተዛውሯል
ምንጩ በቋሚነት ወደ አዲስ URL ተዛውሯል።
ለቋሚ የURL ለውጦች ይጠቀሙ — የፍለጋ ሞተሮች ማውጫቸውን ያዘምናሉ። የSEO ስልጣን ወደ አዲሱ URL ይተላለፋል።
302ተገኝቷል (ጊዜያዊ ዙር)
ምንጩ ለጊዜው በተለየ URL ላይ ይገኛል።
ተገኝቷል (ጊዜያዊ ዙር)
ምንጩ ለጊዜው በተለየ URL ላይ ይገኛል።
ዙሩ ቋሚ አለመሆኑን ያመለክታል። ካሺንግ ከ301 ያነሰ ጥብቅ ነው። እንደ 'መግባት ያስፈልጋል፣ ወደ /login በማዞር ላይ' ላሉ ነገሮች ይጠቀሙ።
303ሌላ ይመልከቱ
GETን በመጠቀም ወደ ተለየ URL ያዙሩ።
ሌላ ይመልከቱ
GETን በመጠቀም ወደ ተለየ URL ያዙሩ።
ከPOST ማስገባቶች በኋላ ጥቅም ላይ ይውላል — ምላሹ 'POSTዎ ሰርቷል፣ ለውጤቱ ይህን GET URL ይመልከቱ' ይላል። አሳሾች ሁልጊዜ አዲሱን URL GET ያደርጋሉ።
304አልተቀየረም
የተከማቸው ስሪት አሁንም ትክክለኛ ነው፤ ይጠቀሙበት።
አልተቀየረም
የተከማቸው ስሪት አሁንም ትክክለኛ ነው፤ ይጠቀሙበት።
ለቅድመ-ሁኔታ ጥያቄ (ከIf-None-Match ወይም If-Modified-Since ራስጌዎች ጋር) ምላሽ። ባንድዊድዝ ይቆጥባል — ምንም አካል አይመለስም።
307ጊዜያዊ ዙር
እንደ 302 ነው ግን የመጀመሪያውን HTTP ስልት ይይዛል።
ጊዜያዊ ዙር
እንደ 302 ነው ግን የመጀመሪያውን HTTP ስልት ይይዛል።
የመጀመሪያው POST ከነበረ፣ ዙሩም POST ይጠቀማል። የስልት ጠባቂነት አስፈላጊ ሲሆን ከ302 ይልቅ ዘመናዊ አማራጭ ነው።
308ቋሚ ዙር
እንደ 301 ነው ግን የመጀመሪያውን HTTP ስልት ይይዛል።
ቋሚ ዙር
እንደ 301 ነው ግን የመጀመሪያውን HTTP ስልት ይይዛል።
POST ጥያቄዎች ከዙር በኋላ POST ሆነው እንዲቆዩ ሲፈለግ ከ301 ይልቅ ዘመናዊ ምትክ ነው።
400ትክክል ያልሆነ ጥያቄ
አገልጋዩ በተሳሳተ አገባብ ምክንያት ጥያቄውን መረዳት አልቻለም።
ትክክል ያልሆነ ጥያቄ
አገልጋዩ በተሳሳተ አገባብ ምክንያት ጥያቄውን መረዳት አልቻለም።
የተለመዱ ምክንያቶች፦ በአካል ውስጥ የተሳሳተ JSON፣ ልክ ያልሆኑ የጥያቄ መለኪያዎች፣ ወይም የጎደሉ አስፈላጊ መስኮች። የጥያቄውን አካል እና ራስጌዎች ያረጋግጡ።
401ያልተፈቀደ
ማረጋገጫ ያስፈልጋል እና አልቀረበም።
ያልተፈቀደ
ማረጋገጫ ያስፈልጋል እና አልቀረበም።
ደንበኛው የማረጋገጫ ማስረጃ (Authorization ራስጌ፣ ኩኪ፣ ቶክን) ማካተት አለበት። 'Unauthorized' የተሳሳተ ስያሜ ነው — በእውነቱ ማለት 'ያልተረጋገጠ' ማለት ነው።
402ክፍያ ያስፈልጋል
ለወደፊት ጥቅም የተያዘ — አልፎ አልፎ ለተከፈለ API ደረጃዎች ጥቅም ላይ ይውላል።
ክፍያ ያስፈልጋል
ለወደፊት ጥቅም የተያዘ — አልፎ አልፎ ለተከፈለ API ደረጃዎች ጥቅም ላይ ይውላል።
በመጀመሪያ ለዲጂታል ክፍያዎች የታሰበ። ዘመናዊ አጠቃቀም፦ ተጠቃሚ የከፈለ ኮታውን ሲያልፍ APIዎች አንዳንዴ 402 ይመልሳሉ።
403የተከለከለ
ደንበኛው ተረጋግጧል ነገር ግን ፈቃድ የለውም።
የተከለከለ
ደንበኛው ተረጋግጧል ነገር ግን ፈቃድ የለውም።
ከ401 የተለየ — ተጠቃሚው ገብቷል፣ ነገር ግን መለያው ለዚህ ምንጭ ፈቃድ የለውም። የሚና/ፈቃድ አመክንዮን ያረጋግጡ።
404አልተገኘም
የተጠየቀው ምንጭ የለም።
አልተገኘም
የተጠየቀው ምንጭ የለም።
ወይ URLው ትክክል አይደለም፣ ምንጩ ተሰርዟል፣ ወይም ፈጽሞ አልነበረም። አገልጋዮች 403 ትክክለኛ ምላሽ መሆኑን ለመደበቅ አንዳንዴ 404 ይመልሳሉ።
405ስልት አልተፈቀደም
ጥቅም ላይ የዋለው HTTP ስልት ለዚህ ምንጭ አይፈቀድም።
ስልት አልተፈቀደም
ጥቅም ላይ የዋለው HTTP ስልት ለዚህ ምንጭ አይፈቀድም።
ለምሳሌ POST ብቻ ወደሚቀበል መድረሻ የGET ጥያቄ። ምላሹ ትክክለኛ ስልቶችን የሚዘረዝር Allow ራስጌ ማካተት አለበት።
406ተቀባይነት የለውም
ከደንበኛው Accept ራስጌዎች ጋር የሚዛመድ ውክልና የለም።
ተቀባይነት የለውም
ከደንበኛው Accept ራስጌዎች ጋር የሚዛመድ ውክልና የለም።
ደንበኛው (በAccept፣ Accept-Language፣ Accept-Encoding በኩል) አገልጋዩ ማሟላት የማይችለውን የይዘት አይነት፣ ቋንቋ ወይም ኢንኮዲንግ ጠይቋል። ብዙ አገልጋዮች ጥብቅ ድርድርን ትተው ነባሪ ይመልሳሉ።
407የፕሮክሲ ማረጋገጫ ያስፈልጋል
ደንበኛው በመጀመሪያ ከፕሮክሲው ጋር መረጋገጥ አለበት።
የፕሮክሲ ማረጋገጫ ያስፈልጋል
ደንበኛው በመጀመሪያ ከፕሮክሲው ጋር መረጋገጥ አለበት።
እንደ 401 ነው፣ ግን በፕሮክሲ ይሰጣል፦ ደንበኛው Proxy-Authorization ማስረጃ መላክ አለበት። በማረጋገጫ ፕሮክሲ ባላቸው የኩባንያ አውታረ መረቦች ላይ ይታያል።
408የጥያቄ ጊዜ አልፏል
አገልጋዩ ጥያቄውን ሲጠብቅ ጊዜው አልፏል።
የጥያቄ ጊዜ አልፏል
አገልጋዩ ጥያቄውን ሲጠብቅ ጊዜው አልፏል።
ደንበኛው የጥያቄውን አካል ለመላክ ብዙ ጊዜ ወስዷል ወይም ግንኙነቱን ስራ ፈት ትቶታል። ጥያቄውን እንደገና ይሞክሩ።
409ግጭት
ጥያቄው ከምንጩ አሁናዊ ሁኔታ ጋር ይጋጫል።
ግጭት
ጥያቄው ከምንጩ አሁናዊ ሁኔታ ጋር ይጋጫል።
በተለምዶ ለተመሳሳይ ጊዜ ማስተካከያ ግጭቶች ወይም የተባዛ ምንጭ ፍጠራ (ለምሳሌ አስቀድሞ ላለ ኢሜይል አዲስ ተጠቃሚ መፍጠር) ይመለሳል።
410ጠፍቷል
ምንጩ ተሰርዟል እና አይመለስም።
ጠፍቷል
ምንጩ ተሰርዟል እና አይመለስም።
ከ404 የበለጠ ጠንካራ ነው — አገልጋዩ ምንጩ ቀደም ሲል እንደነበረ ግን በቋሚነት እንደተወገደ በግልጽ ያውቃል። የፍለጋ ሞተሮች ከማውጫ ያስወግዱታል።
411ርዝመት ያስፈልጋል
አገልጋዩ Content-Length ራስጌ ይፈልጋል።
ርዝመት ያስፈልጋል
አገልጋዩ Content-Length ራስጌ ይፈልጋል።
ጥያቄው Content-Length ራስጌ ስላልነበረው ውድቅ ተደርጓል እና አገልጋዩ ያልታወቀ መጠን ያላቸውን አካላት ይከለክላል። ራስጌውን ጨምረው እንደገና ይሞክሩ።
412ቅድመ-ሁኔታ አልተሳካም
በጥያቄው ራስጌዎች ውስጥ ያለ ሁኔታ አልተሟላም።
ቅድመ-ሁኔታ አልተሳካም
በጥያቄው ራስጌዎች ውስጥ ያለ ሁኔታ አልተሟላም።
እንደ If-Match ወይም If-Unmodified-Since ያሉ ቅድመ-ሁኔታ ራስጌዎች ሲወድቁ ይመለሳል — በተለምዶ ተስፋ ሰጪ መቆለፍ፦ ስሪትዎ ከተገኘ በኋላ ሌላ ሰው ምንጩን ቀይሮታል። እንደገና ይላኩ እና ይሞክሩ።
413የክፍያ ጭነት በጣም ትልቅ ነው
የጥያቄው አካል ከአገልጋዩ የመጠን ገደብ ይበልጣል።
የክፍያ ጭነት በጣም ትልቅ ነው
የጥያቄው አካል ከአገልጋዩ የመጠን ገደብ ይበልጣል።
ትላልቅ ፋይሎች ሲላኩ የተለመደ ነው። የአገልጋይ ውቅር (nginx፣ apache) ከፍተኛ የአካል መጠን ያዘጋጃል። የአገልጋዩን ውቅር ያረጋግጡ።
414URI በጣም ረዥም ነው
የጥያቄው URL ከአገልጋዩ የርዝመት ገደብ ይበልጣል።
URI በጣም ረዥም ነው
የጥያቄው URL ከአገልጋዩ የርዝመት ገደብ ይበልጣል።
ብዙውን ጊዜ በጣም ረጅም የጥያቄ ክሮች (ለምሳሌ በGET ውስጥ ውሂብ ማስቀመጥ) ያስከትሉታል። ወደ POST አካል ይቀይሩ፣ ወይም አገልጋዩን የሚቆጣጠሩ ከሆነ ገደቡን ከፍ ያድርጉ።
415ያልተደገፈ የመገናኛ አይነት
አገልጋዩ የተላከውን Content-Type ማስተናገድ አይችልም።
ያልተደገፈ የመገናኛ አይነት
አገልጋዩ የተላከውን Content-Type ማስተናገድ አይችልም።
ለምሳሌ application/json ብቻ ወደሚቀበል አገልጋይ application/xml መላክ። Content-Type ራስጌን በትክክል ያዘጋጁ።
416ክልል አይረካም
የተጠየቀው የባይት ክልል ከምንጩ መጠን ውጭ ነው።
ክልል አይረካም
የተጠየቀው የባይት ክልል ከምንጩ መጠን ውጭ ነው።
Range ራስጌ ፋይሉ የሌለውን ክፍል ይጠይቃል — ለምሳሌ ፋይሉ ካለቀ በኋላ ማውረድን መቀጠል። ምላሹ ትክክለኛውን መጠን የያዘ Content-Range ማካተት አለበት።
417ግምት አልተሳካም
አገልጋዩ የExpect ራስጌን መስፈርቶች ማሟላት አይችልም።
ግምት አልተሳካም
አገልጋዩ የExpect ራስጌን መስፈርቶች ማሟላት አይችልም።
አገልጋዩ Expect: 100-continue ስለማይደግፍ ይላካል። አንዳንድ ደንበኞች ይህን ራስጌ በነባሪነት ለትላልቅ POSTዎች ይልካሉ፤ ማሰናከል ብዙውን ጊዜ ስህተቱን ይፈታል።
418እኔ የሻይ ማንቆርቆሪያ ነኝ
አገልጋዩ ቡና ማፍላትን ይከለክላል ምክንያቱም የሻይ ማንቆርቆሪያ ስለሆነ።
እኔ የሻይ ማንቆርቆሪያ ነኝ
አገልጋዩ ቡና ማፍላትን ይከለክላል ምክንያቱም የሻይ ማንቆርቆሪያ ስለሆነ።
ከ1998 (RFC 2324) የሚያዝያ አንደኛ ቀልድ። አንዳንድ እውነተኛ APIዎች ለቀልድ ወይም ጊዜ ያለፈባቸውን መድረሻዎች ለማመልከት ይጠቀሙበታል። ለምርት ጥቅም ላይ አይውልም።
421የተሳሳተ አቅጣጫ ያለው ጥያቄ
ጥያቄው ለእሱ ምላሽ መስጠት ወደማይችል አገልጋይ ተልኳል።
የተሳሳተ አቅጣጫ ያለው ጥያቄ
ጥያቄው ለእሱ ምላሽ መስጠት ወደማይችል አገልጋይ ተልኳል።
በHTTP/2 ግንኙነት ድጋሚ አጠቃቀም የተለመደ ነው፦ ጥያቄው ለታለመው ሆስት ስም ያልተዋቀረ አገልጋይ ደርሷል። ደንበኛው በአዲስ ግንኙነት እንደገና መሞከር አለበት።
422ሊሰራ የማይችል ይዘት
ጥያቄው በአገባብ ትክክል ነበር ግን በትርጉም የተሳሳተ ነበር።
ሊሰራ የማይችል ይዘት
ጥያቄው በአገባብ ትክክል ነበር ግን በትርጉም የተሳሳተ ነበር።
ለምሳሌ JSON በትክክል ተነተነ ግን አስፈላጊ መስክ ጎድሏል፣ ወይም የመስክ ዋጋ ከክልል ውጭ ነበር። በREST API ማረጋገጫ ምላሾች ውስጥ የተለመደ ነው።
423ተቆልፏል
ምንጩ ተቆልፏል።
ተቆልፏል
ምንጩ ተቆልፏል።
WebDAV፦ ምንጩ ወይም መድረሻው በሌላ ደንበኛ ተቆልፏል፣ ስለዚህ ክንዋኔው መቀጠል አይችልም። መቆለፊያው እስኪለቀቅ ይጠብቁ ወይም በትክክለኛው ቶክን ይስበሩት።
424ጥገኝነት አልተሳካም
ቀደም ያለ ጥገኛ ጥያቄ ስላልተሳካ ጥያቄው አልተሳካም።
ጥገኝነት አልተሳካም
ቀደም ያለ ጥገኛ ጥያቄ ስላልተሳካ ጥያቄው አልተሳካም።
WebDAV፦ በተከታታይ ጥገኛ ክንዋኔዎች ውስጥ፣ ቀደም ያለ ድርጊት ስላልተሳካ ይህ አልተከናወነም። ለዋናው ምክንያት ቀደመውን ውድቀት ይመልከቱ።
425በጣም ቀደም ብሏል
አገልጋዩ ድጋሚ ሊላክ የሚችል ጥያቄን ማስተናገድ ይከለክላል።
በጣም ቀደም ብሏል
አገልጋዩ ድጋሚ ሊላክ የሚችል ጥያቄን ማስተናገድ ይከለክላል።
ከTLS 1.3 0-RTT (ቀደምት ውሂብ) ጋር የተያያዘ፦ አገልጋዩ ድጋሚ ሊላክ የሚችል ጥያቄን የማስተናገድ አደጋ አይወስድም። ደንበኛው ግንኙነቱ ከተጠናቀቀ በኋላ እንደገና መሞከር አለበት።
426ማሻሻያ ያስፈልጋል
ደንበኛው ወደ ሌላ ፕሮቶኮል መቀየር አለበት።
ማሻሻያ ያስፈልጋል
ደንበኛው ወደ ሌላ ፕሮቶኮል መቀየር አለበት።
አገልጋዩ ጥያቄውን በአሁኑ ፕሮቶኮል ማገልገል ይከለክላል ግን ከማሻሻያ በኋላ ያገለግላል — ምላሹ የሚያስፈልገውን ፕሮቶኮል የሚጠቅስ Upgrade ራስጌ ያካትታል።
428ቅድመ-ሁኔታ ያስፈልጋል
አገልጋዩ ጥያቄው ቅድመ-ሁኔታ ያለው እንዲሆን ይፈልጋል።
ቅድመ-ሁኔታ ያስፈልጋል
አገልጋዩ ጥያቄው ቅድመ-ሁኔታ ያለው እንዲሆን ይፈልጋል።
አገልጋዩ የጠፉ ማዘመኛ ግጭቶችን ለመከላከል ቅድመ-ሁኔታ ራስጌዎችን (እንደ If-Match) ይጠይቃል። ምንጩን ያምጡ፣ ETagውን ይያዙ፣ እና ከIf-Match ጋር እንደገና ይላኩ።
429በጣም ብዙ ጥያቄዎች
ደንበኛው በፍጥነት ገደብ ላይ ነው።
በጣም ብዙ ጥያቄዎች
ደንበኛው በፍጥነት ገደብ ላይ ነው።
ፍጥነትን ይቀንሱ። ምላሹ መቼ እንደገና መሞከር እንዳለበት የሚያመለክት Retry-After ራስጌ ማካተት አለበት። የጥያቄ ኮታ ላላቸው APIዎች የተለመደ ነው።
431የጥያቄ ራስጌ መስኮች በጣም ትልቅ ናቸው
ራስጌዎች አገልጋዩ ለማስኬድ በጣም ትልቅ ናቸው።
የጥያቄ ራስጌ መስኮች በጣም ትልቅ ናቸው
ራስጌዎች አገልጋዩ ለማስኬድ በጣም ትልቅ ናቸው።
ወይ አንድ ራስጌ ወይም አጠቃላይ የራስጌ መጠን ገደቡን ይበልጣል — ብዙውን ጊዜ ከልክ በላይ ትላልቅ ኩኪዎች ያስከትሉታል። ኩኪዎችን ያጽዱ ወይም መተግበሪያዎ በኩኪ የሚያከማቸውን ይቀንሱ።
451በህጋዊ ምክንያቶች አይገኝም
በህጋዊ ጥያቄዎች ምክንያት መዳረሻ ተከልክሏል።
በህጋዊ ምክንያቶች አይገኝም
በህጋዊ ጥያቄዎች ምክንያት መዳረሻ ተከልክሏል።
ምንጩ በህጋዊ ምክንያቶች ታግዷል — ሳንሱር፣ የፍርድ ቤት ትዕዛዞች፣ ወይም የክልል ደንቦች። ቁጥሩ ለFahrenheit 451 ልቦለድ ማጣቀሻ ነው።
500የውስጥ አገልጋይ ስህተት
አገልጋዩ ያልተጠበቀ ሁኔታ አጋጥሞታል።
የውስጥ አገልጋይ ስህተት
አገልጋዩ ያልተጠበቀ ሁኔታ አጋጥሞታል።
ለአገልጋይ-ጎን ስህተቶች አጠቃላይ ማጠቃለያ። ትክክለኛውን ምክንያት ለማወቅ የአገልጋይ ምዝግቦችን ያረጋግጡ፦ ያልተያዘ ልዩ ሁኔታ፣ የመረጃ ቋት ስህተት፣ ወዘተ።
501አልተተገበረም
አገልጋዩ የተጠየቀውን ተግባር አይደግፍም።
አልተተገበረም
አገልጋዩ የተጠየቀውን ተግባር አይደግፍም።
ለምሳሌ አገልጋዩ የHTTP ስልቱን አያውቀውም። በተግባር ላይ ብርቅ ነው — ከዚህ ይልቅ 405 ይታያል።
502መጥፎ በር
አገልጋዩ፣ እንደ በር ሆኖ በሚያገለግልበት ጊዜ፣ ከከፍተኛ አገልጋይ መጥፎ ምላሽ አግኝቷል።
መጥፎ በር
አገልጋዩ፣ እንደ በር ሆኖ በሚያገለግልበት ጊዜ፣ ከከፍተኛ አገልጋይ መጥፎ ምላሽ አግኝቷል።
በማይክሮሰርቪስ አርክቴክቸሮች ውስጥ የተለመደ። ጭነት አመጣጣኝዎ ወይም ግልባጭ ፕሮክሲዎ ከጀርባ አገልግሎቱ ስህተት ያለበት ምላሽ አግኝቷል።
503አገልግሎት አይገኝም
አገልጋዩ ለጊዜው ጥያቄውን ማስተናገድ አይችልም።
አገልግሎት አይገኝም
አገልጋዩ ለጊዜው ጥያቄውን ማስተናገድ አይችልም።
ወይ ለጥገና ተዘግቷል ወይም ጭነት በዝቶበታል። ምላሹ Retry-After ራስጌ ማካተት አለበት። ብዙውን ጊዜ በማሰማራት ወቅት ይመለሳል።
504የበር ጊዜ አልፏል
የበር አገልጋዩ ከፍተኛ አገልግሎት ምላሽ ሲጠብቅ ጊዜው አልፏል።
የበር ጊዜ አልፏል
የበር አገልጋዩ ከፍተኛ አገልግሎት ምላሽ ሲጠብቅ ጊዜው አልፏል።
የጀርባ አገልግሎቱ በበቂ ፍጥነት አልመለሰም። የከፍተኛ አገልግሎት ጤናን እና የጊዜ ማብቂያ ውቅሮችን ያረጋግጡ።
505የHTTP ስሪት አይደገፍም
አገልጋዩ በጥያቄው ውስጥ ጥቅም ላይ የዋለውን የHTTP ስሪት አይደግፍም።
የHTTP ስሪት አይደገፍም
አገልጋዩ በጥያቄው ውስጥ ጥቅም ላይ የዋለውን የHTTP ስሪት አይደግፍም።
የጥያቄው ዋና HTTP ስሪት በአገልጋዩ አይደገፍም። በዘመናዊ ደንበኞች ፈጽሞ አይታይም።
506ተለዋጭም ይደራደራል
አገልጋዩ የይዘት ድርድር ውቅር ስህተት አለው።
ተለዋጭም ይደራደራል
አገልጋዩ የይዘት ድርድር ውቅር ስህተት አለው።
ግልጽ የይዘት ድርድር በዙር ውስጥ ተጠናቅቋል፦ የተመረጠው ተለዋጭ ራሱ ለመደራደር የተዋቀረ ነው። የአገልጋይ ውቅር ስህተትን ያመለክታል።
507በቂ ማከማቻ የለም
አገልጋዩ የዲስክ ቦታ አልቆበታል።
በቂ ማከማቻ የለም
አገልጋዩ የዲስክ ቦታ አልቆበታል።
በመነሻው WebDAV-ተኮር ነው ግን አንዳንዴ በአጠቃላይ አገልጋዮች ጥቅም ላይ ይውላል። ማለት አገልጋዩ በማከማቻ ገደብ ምክንያት ጥያቄውን ማስቀመጥ አልቻለም ማለት ነው።
508ዙር ተገኝቷል
አገልጋዩ ጥያቄውን ሲያስኬድ ማለቂያ የሌለው ዙር አግኝቷል።
ዙር ተገኝቷል
አገልጋዩ ጥያቄውን ሲያስኬድ ማለቂያ የሌለው ዙር አግኝቷል።
WebDAV፦ Depth: infinity ጥያቄን ማስኬድ ወደ ዙር ገባ (ለምሳሌ ክብ ትስስሮች)። ክንዋኔው ተቋርጧል።
510አልተስፋፋም
ለጥያቄው ተጨማሪ ማስፋፊያዎች ያስፈልጋሉ።
አልተስፋፋም
ለጥያቄው ተጨማሪ ማስፋፊያዎች ያስፈልጋሉ።
ከቆየው HTTP Extension Framework፦ አገልጋዩ ጥያቄውን ከመፈፀሙ በፊት ተጨማሪ መረጃ ያስፈልገዋል። በዘመናዊው ድር ውስጥ በተግባር ጥቅም ላይ አይውልም።
511የአውታረ መረብ ማረጋገጫ ያስፈልጋል
ደንበኛው ለአውታረ መረብ መዳረሻ መረጋገጥ አለበት።
የአውታረ መረብ ማረጋገጫ ያስፈልጋል
ደንበኛው ለአውታረ መረብ መዳረሻ መረጋገጥ አለበት።
ተጠቃሚው ወደ ውጫዊ ጣቢያዎች ከመድረሱ በፊት ወደ አውታረ መረቡ መግባት እንዳለበት ለማመልከት በምርኮኛ ፖርታሎች (ሆቴል/አየር ማረፊያ ዋይፋይ) ጥቅም ላይ ይውላል።
እንዴት እንደሚሠራ
ይህ መሣሪያ በአሳሹ ውስጥ የሚሠራ ማጣቀሻ ሲሆን አምስቱንም ክፍሎች (1xx–5xx) የሚሸፍኑ 63 የHTTP ሁኔታ ኮዶች ባሉበት ቋሚ የማጣቀሻ ሰንጠረዥ ዙሪያ የተገነባ ነው፤ እያንዳንዱ የሚገልጸው የRFC ቁጥር ተጽፎበታል። ምንም የአገልጋይ ጥሪ፣ ምንም ውጫዊ API፣ ምንም የአውታረ መረብ ጥያቄ የለም — ሁሉም ማጣራት እና ማሳየት በአሳሹ ውስጥ በJavaScript አብሮገነብ የድርድር እና የሕብረቁምፊ ዘዴዎች ይከናወናል።
- 1የማጣቀሻ ሰንጠረዡ ይጫናልበIANA የተመዘገቡት ሙሉዎቹ 63 የሁኔታ ኮዶች እንደ JavaScript ድርድር በቀጥታ በዚህ መሣሪያ ውስጥ ተካትተዋል፤ እያንዳንዱ ግቤት የቁጥር ኮዱን፣ መደበኛውን የእንግሊዝኛ ስም፣ የምድብ ክፍሉን እና የሚገልጸውን የተወሰነ RFC ይይዛል (ለምሳሌ ለአብዛኞቹ የHTTP/1.1 ኮዶች RFC 9110፣ ለ429 Too Many Requests RFC 6585፣ ለ418 I'm a Teapot RFC 2324)።
- 2ማጣራቱ በማህደረ ትውስታ ውስጥ ይሠራልሲተይቡ ወይም የምድብ ማጣሪያ ሲመርጡ፣ የJavaScript Array.filter በማህደረ ትውስታ ውስጥ ባለው ዝርዝር ላይ ይሠራል፤ ጥያቄዎን ከሁኔታ ኮድ ቁጥሩ፣ ከመደበኛው ስም እና ከአጭሩ እና ረጅሙ የመግለጫ ሕብረቁምፊዎች ጋር በString.includes ያዛምዳል — ምንም መዘግየት፣ ምንም የአገልጋይ ምልልስ የለም።
- 3ዝርዝሮቹ ከRFC አገናኝ ጋር ይዘረጋሉእያንዳንዱ ውጤት እንደ HTML details/summary አካል ይታያል። አንድን ግቤት መዘርጋት ረጅሙን ማብራሪያ እና በrfc-editor.org ላይ ወዳለው ባለሥልጣን RFC ቀጥተኛ አገናኝ ያሳያል፤ ስለዚህ ለማንኛውም ኮድ ትክክለኛውን የመስፈርት ጽሑፍ ማንበብ ይችላሉ።
- 4ቀጥተኛ አገናኞች እና ወደ ቅንጥብ ሰሌዳ መቅዳትአንድን ግቤት መክፈት የURL hashን ወደ ኮድ ቁጥሩ ያዘምናል (ለምሳሌ #404)፤ ይህም ገጹን ሊጋራ እና ዕልባት ሊደረግበት የሚችል ያደርገዋል። የቅዳ አዝራሩ መደበኛውን ሕብረቁምፊ (ለምሳሌ '404 Not Found') በአሳሹ navigator.clipboard API ወደ ቅንጥብ ሰሌዳ ይጽፋል።
ተዛማጅ መሳሪያዎች
ጥቅስ አመንጪ
ለድህረ ገጾች፣ መጻሕፍት፣ ጆርናሎች እና YouTube APA 7, MLA 9, Chicago እና Harvard ጥቅሶችን እና ውስጥ-ጽሑፍ ማጣቀሻዎችን ይፍጠሩ — እና ለቅዳት ወይም ወደ ውጭ ለመላክ የማጣቀሻ ዝርዝር ይገንቡ። ነፃ፣ የግል፣ ያለ ማስታወቂያ።
QR ኮድ ፈጣሪ
ለURL፣ ጽሑፍ፣ WiFi እና ሌሎች QR ኮዶችን ፍጠሩ። ምንም ውሃ ምልክት የለም።
የቀለም መምረጫ እና ፓሌት ፈጣሪ
ቀለሞችን ይምረጡ፣ ከ HEX/RGB/HSL መካከል ቀይሩ፣ እና ተስማሚ ፓሌቶችን ፍጠሩ።