အဓိကအကြောင်းအရာသို့ ကျော်သွားရန်

အခမဲ့ HTTP အခြေအနေကုဒ်ကိုးကားချက်

HTTP status code အားလုံး — တစ်ခုချင်း မည်သို့ အဓိပ္ပာယ်ရှိသည်၊ မည်သောအခါ သုံးသည် နှင့် common ဖြစ်ရသော အကြောင်းရင်းများ — searchable ကိုးကားနည်း ။ 100 မှ 511 ထိ。

Load ပြီးသည်နှင့် offline အလုပ်လုပ်သည်

61 status code

100

ဆက်လက်ခြင်း

ဆာဗာ သည် တောင်းဆိုခွင့် အစီအစဉ် အများစုကို လက်ခံပြီးပြီ၊ ကလိုင်းဒ် သည် ကွန်ယက်အမှုအခင်း ဆက်လုံ့နိုင်သည်။

Expect: 100-continue နှင့် တွဲဖက်သည့် တောင်းဆိုခွင့်များအတွက် အသုံးပြုခြင်း။ ကလိုင်းဒ် ကွန်ယက်အမှုအခင်း ကျေးဇူးပြုပေးမည်ဟု ကုံးကွဲခြင်း။ ခေတ်သစ် ကွန်ယက်အပ်လီကေးရှင်းများတွင် ရarelyလုံ့လုံ့စျေးမှီ ကြေးမုံမှုများ မခြင်း။

RFC 9110 ↗
101

ပရိုတိုကောနြ ပြောင်းလဲခြင်း

ဆာဗာ သည် ကလိုင်းဒ် မှ တောင်းဆိုသည့် ပရိုတိုကောနြများ ပြောင်းလဲလျက်ရှိသည်။

အများအားဖြင့် WebSocket မွှေးအဟောင်းရှေ့သို့ အသုံးပြုခြင်း — ကလိုင်းဒ် သည် Upgrade: websocket တောင်းဆိုခြင်း ပြုလုပ်ပြီး ဆာဗာ သည် 101 သည့်သုံးဆုံးခြင်းဖြင့် အဓိပ္ပါယ်ရှုံးခြင်း။

RFC 9110 ↗
102

လုပ်ဆောင်စဉ်အခါ

ဆာဗာ သည် တောင်းဆိုခွင့် လက်ခံ၍ အလုပ်လုပ်လျက်ရှိသည်၊ သို့သော် မည်သည့် အလေးအပင် မရှိသေးခြင်း။

WebDAV ကြားခံ အလေးအပင်ခြင်း၊ ကလိုင်းဒ် အချိန်မီခြင်း ကာကွယ်ရန်အတွက် လုပ်ဆောင်မှုများကြာကျေးဇူးပြုခြင်း။ အရေးအသားဖျက်ခြင်း — ခေတ်သစ် ဆာဗာများ သည် မည်သည့်အခါမျှ မစေခြင်း နိုင်ခြင်း။

RFC 2518 ↗
103

ကြိုတင်အရည်အချင်း

နောက်ဆုံး အလေးအပင်မီ ကြိုတင်အစီအစဉ် ပေးလွှတ်ခြင်း။

ဆာဗာများ လင်ခ် အစီအစဉ်များ (အကြိုချိတ်ဆက်/အကြိုဆက်စပ်) မြှုပ်နှံသည့်အခါ အဖြစ်အပျက်များ ချည်မျှင်းစုံ ချီးခြင်း ခြင်းများ မီးမှုံကြားခြင်း၊ အုပ်စုချုပ်ခွင့် ဝင်နိုင်ခြင်း။

RFC 8297 ↗
200

အိုကေ

တောင်းဆိုခွင့် အောင်မြင်သည်။

ကျော်မြောက်သည့် အလေးအပင်ခြင်း သည် HTTP နည်းဟောင်းအပေါ် မူတည်သည် - GET → သည့်သုံးဆုံး ပြန်လည်ခြင်း၊ POST/PUT → လုပ်ဆောင်မှု ဆည်းဖူးခြင်း။

RFC 9110 ↗
201

ဖန်တီးခြင်း

အသစ် သည့်သုံးဆုံး အောင်မြင်စွာ ဖန်တီးခြင်း။

POST အပြီးမကြေးယုံ။ အလေးအပင်သည် အသစ် သည့်သုံးဆုံး၏ URL ကိုည်သည့်သုံးဆုံး အစီအစဉ် ဆုံးခြင်း နိုင်သည်။

RFC 9110 ↗
202

လက်ခံခြင်း

တောင်းဆိုခွင့် လုပ်ဆောင်မှုအတွက် လက်ခံခြင်း၊ သို့သော် လုပ်ဆောင်မှု မဆည်းဖူးသေးခြင်း။

တည်းဖြတ်မွှေးတည့်မြူ လုပ်ဆောင်မှုများအတွက် — ဆာဗာ သည် လုပ်ဆောင်မှု အုပ်စုချုပ်ခွင့်ခြင်း။ ကလိုင်းဒ် သည် အခြေအနေ အစီအစဉ်အတွင်း အုပ်စုချုပ်ခွင့် ကျေးဇူးပြုခြင်း သို့မဟုတ် နောက်မှ ထပ်မံ ကြည့်ရှုခြင်း။

RFC 9110 ↗
203

မဟုတ်သည့် အစီအစဉ်

အလေးအပင် သည် ပြန်လည်ထည့်သွင်းအုပ်စု မှ ပြောင်းလဲခြင်း။

တောင်းဆိုခွင့် အောင်မြင်သည်၊ သို့သော် ကြားခံအုပ်စု (ဥပမာ - သည့်သုံးဆုံးချုပ်ခွင့် သို့မဟုတ် ပြန်လည်ထည့်သွင်းအုပ်စု) မူလဆာဗာမှ အများစုကို ပြောင်းလဲခြင်း — ဥပမာ၊ ပုံများ ထပ်မံ ချုံခြင်း။ လုံ့လုံ့စျေးမှီ ကြေးမုံမှုများတွင်။

RFC 9110 ↗
204

အများစုမရှိခြင်း

တောင်းဆိုခွင့် အောင်မြင်သည်၊ သို့သော် အလေးအပင် အများစု မရှိခြင်း။

ကုဒ်ဖျက်ခြင်း လုပ်ဆောင်မှုများ သို့မဟုတ် PUT အဆင့်မြှင့်တင်ခြင်းများအတွက် အများအားဖြင့် အသုံးပြုခြင်း။ ကလိုင်းဒ် သည် လက်ရှိ စာမျက်နှာမှ အဖြစ်အပျက်ရှုံးခြင်း မလုပ်နိုင်သည်။

RFC 9110 ↗
205

အများစုပြန်အစ

တောင်းဆိုခွင့် အောင်မြင်သည်၊ ကလိုင်းဒ် သည် စာမျက်နှာကြည့်မှု ပြန်အစခြင်း။

အနည်းငယ် 204 ကဲ့သို့ အများစု မပြန်လည်ခြင်း — သို့သော် ကလိုင်းဒ် သည် အခြင်း အုပ်စု သို့မဟုတ် အလှပ်ခြင်း ပြန်ဆုံးခြင်း (ဥပမာ အခြင်း ဖိုင်များ နောက်ထပ် ထည့်သွင်းအတွက် အလွတ်လုပ်ခြင်း) သည့်သုံးဆုံးခြင်း။

RFC 9110 ↗
206

သည့်သုံးဆုံးအများစု

ဆာဗာ သည့်သုံးဆုံး၏ အများစုသည်ပါးတီကအတိုင်း ပေးလွှတ်ခ�င်း။

ကြီးလေးကျွန်း တောင်းဆိုခွင့်အတွက် အလေးအပင်ခြင်း။ ကလီပ်ခွင့်သည့် အဆင်း သည့်သုံးဆုံး ပြန်လည်ခြင်း သို့မဟုတ် ကြီးလေးကျွန်း ဖိုင်များ ချိတ်ဆက်ခြင်းအတွက် အုပ်စုချုပ်ခွင့် ကျေးဇူးပြုခြင်း နှင့် ဒေါင်းလုဒ်ခွင့် ကျေးဇူးပြုခြင်း။

RFC 9110 ↗
207

အများစုအခြေအနေ

အလေးအပင် အများစု သည်အများစုအခြေအနေ ကုဒ် လုပ်ဆောင်မှုများ ကျေးဇူးပြုခြင်း။

WebDAV - XML အများစုသည် အလုပ်ချုပ်ခွင့်အများစု၏ အလေးအပင်ကို လွတ်လွတ်ကွင်း ခွင်း — ဥပမာ အုပ်စုအဖွဲ့ မကျေးဇူးရှိခြင်း ဆက်လုံ့ အုပ်စုအဖွဲ့ အများအားဖြင့် အောင်မြင် အနည်းငယ် အမှားအယွင်း။

RFC 4918 ↗
208

ပြန်လည်အစီကျခြင်း

အုပ်စုတွင်း အုပ်စုများ သည် အလေးအပင်တွင် အုံရှေ့မှ စာရင်းသွင်းခြင်း။

WebDAV - အများစုအခြေအနေ အလေးအပင်များတွင် အသုံးပြုခြင်း အုပ်စုခွင်း အုပ်စုတွင်း အုပ်စုများကို ထပ်မံ စာရင်းသွင်းခြင်း ကာကွယ်ရန် ကင်းလွတ်ခြင်း။

RFC 5842 ↗
226

IM အသုံးပြုခြင်း

အလေးအပင် သည် သည့်သုံးဆုံးအပေါ် အတည်ပြုများ သုံးဆုံးခြင်း။

ခွဲခြင်းအင်္ကုဒ် - ဆာဗာ သည့်သုံးဆုံး မကြေးယုံ မူလ ဖိုင်၏ အညွှန်း ပေးလွှတ်ခြင်း၊ ကွန်ယက်အလွှမ်းအား ရေရှည်ခြင်း။ အတင်းအဆန်း ရေရှည်အသုံးပြုခြင်း။

RFC 3229 ↗
300

အများအလွှမ်းရွေးချယ်ခွင့်

သည့်သုံးဆုံး၏ အများအလွှမ်းအုပ်စုလုပ်ခြင်း ရှိခြင်း။

ဆာဗာ အများအလွှမ်း ရွေးချယ်ခွင့်များ (ဥပမာ မတူညီသည့် အုပ်စုများ သို့မဟုတ် ဘာသာစကားများ) နှင့် ကလိုင်းဒ် သည် တစ်ခု ရွေးချယ်သင့်သည်။ အများအားဖြင့် အသုံးပြုခြင်း မဟုတ်ခြင်း၊ သုံးဆုံးအလွှမ်း သုံးဆုံးအုပ်စု အများအားဖြင့် ကုံးကွဲခြင်း။

RFC 9110 ↗
301

ထာဝရ လွှမ်းခြင်း

သည့်သုံးဆုံး သည် ထာဝရ အသစ် URL သို့ လွှမ်းခြင်း။

ထာဝရ URL ပြောင်းလဲခြင်းများအတွက် အသုံးပြုခြင်း — ရှာဖွေခွင့်အုပ်စုများ သည် အစီအစဉ်တွင် အဆင့်မြှင့်တင်ခြင်း။ SEO အာဏာ အသစ် URL သို့ လွှမ်းခြင်း။

RFC 9110 ↗
302

ရှာလုံ့သည်ခြင်း (အခိုင်အမဲ လွှမ်းခြင်း)

သည့်သုံးဆုံး သည် အခိုင်အမဲ အသစ် URL သို့ အခြေအနေ။

လွှမ်းခြင်း ထာဝရ မဟုတ်သည်ဟု အကြံဉာဏ်။ မြှုပ်နှံခြင်း သည် 301 ထက် အောင်မြင်မှု လျော့နည်းခြင်း။ အရာများ ကဲ့သို့ အသုံးပြုခြင်း 'login လိုအပ်ခြင်း၊ /login သို့ လွှမ်းခြင်း'။

RFC 9110 ↗
303

အခြား ကြည့်ရှုခြင်း

GET အသုံးပြုခြင်းအတွက် အသစ် URL သို့ လွှမ်းခြင်း။

POST အတည်ပြုလွှမ်းခြင်းများအပြီးမကြေးယုံ — အလေးအပင် သည် 'သင့် POST အောင်မြင်သည်၊ ဤ GET URL ကြည့်ရှုခြင်းအတွက် အလေးအပင်ခြင်း'။ ကွန်ယက်သည့်သုံးဆုံး အများအားဖြင့် GET အသစ် URL။

RFC 9110 ↗
304

မပြောင်းလဲခြင်း

မြှုပ်နှံခြင်း သည် အခိုင်အမဲ လုံ့ခြင်း၊ ထည့်သွင်းခြင်း။

အခြေအနေအုပ်စု တောင်းဆိုခွင့် လုပ်ဆောင်မှုများ (If-None-Match သို့မဟုတ် If-Modified-Since အစီအစဉ်များ သည့်သုံးဆုံး။ ကွန်ယက်အလွှမ်းအား ရေရှည်ခြင်း — အများစု မပြန်လည်ခြင်း။

RFC 9110 ↗
307

အခိုင်အမဲ လွှမ်းခြင်း

302 ကဲ့သို့ သို့သော် မူလ HTTP နည်းဟောင်း လုံ့လုံ့ခွင့်။

မူလ POST ဖြစ်ခြင်း၊ လွှမ်းခြင်း သည် POST သုံးဆုံးခြင်း။ ခေတ်သစ် အခြင်း 302 ကြည့်ရှုခြင်းဖြင့် နည်းဟောင်း လုံ့လုံ့ခွင့်။

RFC 9110 ↗
308

ထာဝရ လွှမ်းခ�င်း

301 ကဲ့သို့ သို့သော် မူလ HTTP နည်းဟောင်း လုံ့လုံ့ခွင့်။

ခေတ်သစ် အစားထိုးခြင်း 301 သည့်သုံးဆုံးအတွက် POST တောင်းဆိုခွင့် လွှမ်းခြင်းအပြီးမကြေးယုံ အခိုင်အမဲ သည့်သုံးဆုံးခြင်း။

RFC 9110 ↗
400

အမှားအယွင်းတောင်းဆိုခွင့်

ဆာဗာ သည် အမှားအယွင်းစာသားတွင် အတည်ပြုခြင်း မဟုတ်ခြင်း။

ယုံယုံကြည် ကြေးမုံမှုများ - JSON အများစုတွင် အမှားအယွင်း၊ အမှားအယွင်း အုပ်စုအုပ်ခွင့်များ၊ သို့မဟုတ် လိုအပ်သည့် ဖိုင်များ ပျက်ယွင်းခြင်း။ တောင်းဆိုခွင့် အများစု နှင့် အစီအစဉ်များ ကြည့်ရှုခြင်း။

RFC 9110 ↗
401

အုပ်စုခွင်းမရှိခြင်း

အုပ်စုခွင်း လိုအပ်သည့်အခါ ပေးလွှတ်မည်ည်။

ကလိုင်းဒ် သည် အစီအစဉ် အုပ်စုခွင်း (အုပ်စုခွင်း အစီအစဉ်၊ မီး၊ အများစု) ပါဆန်တင်ခြင်း။ 'Unauthorized' သည် အမှားအယွင်း — ဆိုလိုသည် 'မထည့်သွင်းခြင်း' ။

RFC 9110 ↗
402

ငွေပေးချေခွင့် လိုအပ်ခြင်း

အနာဂတ် အသုံးပြုခွင့်အတွက် ကိုင်သည့်သုံးဆုံး — တစ်ခါတစ်ရံ အခောင်းအရာများ API အများစုများအတွက် အသုံးပြုခြင်း။

မူလ အီလက်ထရောနစ် ငွေပေးချေခွင့်များအတွက် အဆင်သင့်မွှေး။ ခေတ်သစ် အသုံးပြုခြင်း - API များ အများအားဖြင့် 402 အလေးအပင်ခြင်း သည့်သုံးဆုံးလုံ့နည်းခွင့်ကျေးဇူးသုံး ခြင်း။

RFC 9110 ↗
403

ကန့်သတ်ခြင်း

ကလိုင်းဒ် လုံ့လုံ့အုပ်စုခွင်း သည့်သုံးဆုံး ခွင့်မရှိခြင်း။

401 မှ ကွဲခြင်း — သည့်သုံးဆုံး ပိုင်ဆိုင်ရှိသည်၊ သို့သော် သည့်သုံးဆုံးမင်း ဤသည့်သုံးဆုံးအတွက် ခွင့်မရှိခြင်း။ အုပ်စုခွင့်/ခွင့်များ ယုံယုံကြည် သုံးဆုံးခြင်း။

RFC 9110 ↗
404

မကျေးဇူးခြင်း

တောင်းဆိုခွင့် သည့်သုံးဆုံး မရှိခြင်း။

URL အမှားအယွင်း၊ သည့်သုံးဆုံး ဖျက်သိမ်းခြင်း၊ သို့မဟုတ် မည်သည့်အခါမျှ မရှိခြင်း။ ဆာဗာများ တစ်ခါတစ်ရံ 404 အလေးအပင်ခြင်း 403 ကို အများအားဖြင့် အလွတ်ခြင်း။

RFC 9110 ↗
405

HTTP နည်းဟောင်း ခွင့်မရှိခြင်း

HTTP နည်းဟောင်း အသုံးပြုခြင်း သည့်သုံးဆုံးအတွက် ခွင့်မရှိခြင်း။

ဥပမာ - GET တောင်းဆိုခွင့် အုပ်စုခွင့် POST သည့်သုံးဆုံး။ အလေးအပင် သည် အစီအစဉ်များ စာရင်းသွင်းခြင်း လုံ့ လုံ့ လိုအပ်သည်။

RFC 9110 ↗
406

လက်ခံခွင့်မရှိခြင်း

အုပ်စု အုပ်ကျ ကလိုင်းဒ် လက်ခံခြင်း အစီအစဉ်များ နှင့် မကိုက်မီခြင်း။

ကလိုင်းဒ် တောင်းဆိုခြင်း အများစု အုပ်စု (via လက်ခံခြင်း၊ လက်ခံခြင်း ဘာသာစကား၊ လက်ခံခြင်း အင်္ကုဒ်) ဆာဗာ မစာသည့် အရွယ်အစား။ အများ ဆာဗာများ တင်ကြေးစီးမျက်နှာ သုံးဆုံးခြင်း အစားထိုးခြင်း ပုံစံ။

RFC 9110 ↗
407

ပရော်ဆီ အုပ်စုခွင်း လိုအပ်ခြင်း

client သည် proxy နှင့် အရင် authenticate လုပ်ရမည်။

401 ကဲ့သို့၊ သို့သော် ပရော်ဆီ မှ အုပ်စုခွင်း - ကလိုင်းဒ် သည် ပရော်ဆီ အုပ်စုခွင်း အုပ်စုခွင်း ပေးလွှတ်ခြင်း။ ကောင်ပဏီ ကွန်ယက်များတွင် အုပ်စုခွင်း ပရော်ဆီများ ကြည့်ရှုခြင်း။

RFC 9110 ↗
408

တောင်းဆိုမှု အချိန်ကုန်

ဆာဗာသည် တောင်းဆိုမှုအတွက် စောင့်ဆိုင်းချိန် ကုန်ခဲ့သည်။

client သည် တောင်းဆိုမှု body ကို ပို့ရန် သို့မဟုတ် ချိတ်ဆက်မှုကို အလုပ်မရှိဘဲ ထားရန် အချိန်ကြာလွန်းသည်။ တောင်းဆိုမှုကို ထပ်မံကြိုးစားပါ။

RFC 9110 ↗
409

ရုန်းကန်မှု

တောင်းဆိုမှုသည် အရင်းအမြစ်၏ လက်ရှိအခြေအနေနှင့် ရုန်းကန်နေသည်။

များသောအားဖြင့် တစ်ပြိုင်တည်းတည်းဖြတ်မှု ပဋ္ဌbolton များ သို့မဟုတ် အရင်းအမြစ်ကို ကျော်လွန်စွာ ဖန်တီးမှု (ဥပမာ - ရှိသားနှင့်အီမေလ်ဆီသုံးအသုံးပြုသည့် အသုံးပြုသူတစ်ယောက်ကိုဖန်တီးခြင်း) အတွက် ပြန်လည်ပြည့်ဝစေသည်။

RFC 9110 ↗
410

သွားလွှားခဲ့သည်

အရင်းအမြစ်ကိုဖျက်သိမ်းခဲ့ပြီး ပြန်လည်မလည်ပန်းမည်။

404 ထက် ပိုပြီးအားကောင်းသည် - ဆာဗာသည် အရင်းအမြစ်သည် အရင်တစ်ခါ ရှိခဲ့သော်လည်း ယခု အစီအစဥ်ဖြင့် ဖယ်ရှားလျက်ရှိသည်ကို သိသည်။ ရှာဖွေမှုအင်ဂျင်များသည် အညွှန်းကိုဖျက်လိမ့်မည်။

RFC 9110 ↗
411

အလျား လိုအပ်သည်

ဆာဗာသည် Content-Length ခေါင်းစဉ်ကို လိုအပ်သည်။

တောင်းဆိုမှုကို Content-Length ခေါင်းစဉ်မှ ကင်းမဲ့ပြီး ဆာဗာသည် အရွယ်အစားမသိသော အလုံးအစုများကိုငြင်းဆန်သည်ကြောင့် ငြင်းပယ်ခဲ့သည်။ ခေါင်းစဉ်ကိုထည့်သွင်းပြီးထပ်မံကြိုးစားပါ။

RFC 9110 ↗
412

အခြေအနေ မပြည့်မကုံ

တောင်းဆိုမှု ခေါင်းစဉ်ရှိ အခြေအနေ မကျေးဇူးပြုခဲ့။

If-Match သို့မဟုတ် If-Unmodified-Since ကဲ့သို့သော အခြေအနေကျ ခေါင်းစဉ်များ ကျခြင်းအခါ ပြန်လည်ပြည့်ဝစေသည် - များသောအားဖြင့် အကဲဆတ်ရမှု သော့ခြင်း - အခြား သူတစ်ဦးက အင်္ဂါရပ်အရင်းအမြစ်ကို ပြောင်းလဲသည်။ ပြန်လည်ဆွဲခြင်းအလုံးအစုနှင့် ထပ်မံကြိုးစားပါ။

RFC 9110 ↗
413

အလုံးအစု အလွန်အများ

တောင်းဆိုမှု အလုံးအစုသည် ဆာဗာ၏ အရွယ်အစား ကန့်သတ်မှုကို ကျော်လွန်သည်။

အကြီးမားသောဖိုင်များအားလုံးမိုးများ ဆင်းပြေစေသည့်အခါ ပုံမှန်ဖြစ်သည်။ ဆာဗာ အပ်များ (nginx, apache) သည် အများဆုံးအလုံးအစုအရွယ်အစားကို သတ်မှတ်သည်။ ဆာဗာ ပုံစံကိုစစ်ဆေးပါ။

RFC 9110 ↗
414

URI အလွန်ကြီးမားသည်

တောင်းဆိုမှု URL သည် ဆာဗာ၏ အလျား ကန့်သတ်မှုကို ကျော်လွန်သည်။

များသောအားဖြင့် အလွန်ကြီးမားသော မေးခွန်းဆိုမှု ကြိုးများ (ဥပမာ - GET မှ ဒေတာကို စာဝှက်ခြင်း) ကြောင့် ဖြစ်သည်။ POST အလုံးအစုသို့ မည်သည့် အရွယ်အစားကို ကန့်သတ်သည့် ဆာဗာ ကန့်သတ်မှုကို မြှင့်တင်သည့် အခြင်းအရင်း။

RFC 9110 ↗
415

အကူအညီမပေးသော မီဒီယာ အမျိုးအစား

ဆာဗာသည် ပို့ဆောင်ထားသော Content-Type ကို ကိုင်တွယ်မည်မဟုတ်။

ဥပမာအားဖြင့် application/xml ကို application/json သာ လက်ခံသည့် ဆာဗာသို့ ပို့ခြင်း။ Content-Type ခေါင်းစဉ်ကို မှန်ကန်စွာ သတ်မှတ်ပါ။

RFC 9110 ↗
416

Range မကျေးဇူးပြု

တောင်းဆိုထားသည့် ဘိုက် အကွာအဝေးသည် အရင်းအမြစ်၏ အရွယ်အစားအပြင်ဘက်တွင်ရှိသည်။

Range ခေါင်းစဉ်သည် ဖိုင်သည့် မကျေးဇူးပြုမည်ဆိုသည့် အစိတ်အပိုင်းကိုတောင်းဆိုသည် - ဥပမာ - ဖိုင်၏ အဆုံးအနံပြီးကျော်လွန်ထိုးဖြင့် ကျင့ွန်ထည့်ခြင်း။ တုံ့ပြန်ချက်တွင် Content-Range သည် စစ်ဆေးသည့် အရွယ်အစားကိုထည့်သွင်းရမည်။

RFC 9110 ↗
417

အမျှော်မှားသည်

ဆာဗာသည် Expect ခေါင်းစဉ်၏ လိုအပ်သည့်အရာများကို ကျေးဇူးပြုမည်မဟုတ်။

ဆာဗာသည် Expect: 100-continue ကိုအလျား မလုပ်ဆောင်သောအခါ ပို့ဆောင်သည်။ အချို့ ကလိုင်းများသည် ကြီးမားသော POSTs ပေါ်တွင် ဤခေါင်းစဉ်ကို ပုံမှန်အားဖြင့် ပို့ဆောင်ပြီး၎င်းကိုအလျား မပြုလုပ်သည့်အခါ အများအားဖြင့် အမှားအယွင်းကို ဖြေလည်သည်။

RFC 9110 ↗
418

ကျွန်ုပ်သည် လက်ခင်းပုံးဖြစ်သည်

ဆာဗာသည် လက်ခင်းပုံးဖြစ်သောကြောင့် ကော်ဖီ ချက်ခြင်းကို ငြင်းဆန်သည်။

၁၉၉၈ ခုနှစ်မှ တစ်ပြေးအရူမျ (RFC 2324)။ အချို့ တကယ် APIs များသည် အရူမျများသို့မဟုတ် ဆုံးရှုံးသည့်အနေအထားများကိုအထင်အမြင်ထည့်သွင်းရန်အတွက်၎င်းကိုအသုံးပြုသည်။ ထုတ်ဝေမှုအသုံးပြုမှုများအတွက်မဟုတ်။

RFC 2324 ↗
421

လမ်းမှားသည့် တောင်းဆိုမှု

တောင်းဆိုမှုကို တုံ့ပြန်မှုကို ဖန်တီးမည်မဟုတ်သည့် ဆာဗာသို့ ပို့ဆောင်ခဲ့သည်။

HTTP/2 ချိတ်ဆက်မှု ပြန်သုံးခြင်းတွင် ပုံမှန်ဖြစ်သည်- တောင်းဆိုမှုသည် ပစ်မှတ် hostname အတွက် ပြင်ဆင်မထားသော ဆာဗာသို့ ရောက်သွားသည်။ client သည် ချိတ်ဆက်မှုအသစ်ဖြင့် ထပ်ကြိုးစားသင့်သည်။

RFC 9110 ↗
422

ဖန်တီးမည်မဟုတ်သည့် အကြောင်းအရာ

တောင်းဆိုမှုသည် ကျိုးကောင်းစွာမည်သော်လည်း အဓိပ္ပာယ်ဖြင့် မှားနေသည်။

ဥပမာအားဖြင့် JSON သည် မှန်ကန်စွာခွဲခြမ်းစိတ်ဖြာခဲ့သော်လည်း လိုအပ်သည့်စာအုပ်မှာ မပါရှိခြင်း သို့မဟုတ် စာအုပ်တန်ဖိုးသည် အကွာအဝေးမပြည့်သည်။ REST API အတည်ပြုမှု တုံ့ပြန်မှုများတွင် ပုံမှန်ဖြစ်သည်။

RFC 9110 ↗
423

သော့ခြင်း

အရင်းအမြစ်သည် သော့ခြင်းခံထားသည်။

WebDAV- မူရင်း သို့မဟုတ် ပစ်မှတ်အရင်းအမြစ်သည် အခြား client တစ်ခုက သော့ခတ်ထားသဖြင့် လုပ်ဆောင်မှု ဆက်လုပ်၍ မရပါ။ သော့ပြန်ဖွင့်သည်အထိ စောင့်ပါ သို့မဟုတ် သင့်လျော်သော token ဖြင့် ဖြုတ်ပါ။

RFC 4918 ↗
424

အချုပ်မျှသည့် အမှားအယွင်း

တောင်းဆိုမှုသည် အစောမှ အချုပ်မျှသည့် တောင်းဆိုမှု ပျက်ကွက်သောကြောင့် ပျက်ကွက်သည်။

WebDAV - အချုပ်မျှသည့် လုပ်ဆောင်မှုများ၏ သည့် - အစောမှ လုပ်ဆောင်မှုသည် ပျက်ကွက်သည်ကြောင့် ၎င်းကို လုပ်ဆောင်မထားပါ။ အစောမှ အမှားအယွင်းကိုလျှော့လည်းခြင်း အရင်းအမြစ်အတွက်ကြည့်ရှုပါ။

RFC 4918 ↗
425

အလွန်အစောဖြစ်သည်

ဆာဗာသည် ပြန်လည်ခွင့်ပြုထားသည့်အလားအလာရှိသည့် တောင်းဆိုမှုကို ဖန်တီးမည်ငြင်းဆန်သည်။

TLS 1.3 0-RTT (အစောသည့် ဒေတာ) ညီညွတ်သည့်အခါ - ဆာဗာသည် အလားအလာ ပြန်လည်ခွင့်ပြုထားသည့် တောင်းဆိုမှုကို ဖန်တီးမည်ကို ကန်ကျန်မည်မဟုတ်။ ကလိုင်းသည် စက်ဆန်ဒ ပြီးမှ ထပ်မံကြိုးစားရမည်။

RFC 8470 ↗
426

အဆင့်မြှင့်တင်မှု လိုအပ်သည်

ကလိုင်းသည် သည့်အဆင့်မြှင့်တင်သည့် စီမံခန့်ခွဲမှုသို့ အဆုံးအဖြတ်ရသည်။

ဆာဗာသည် လက်ရှိစီမံခန့်ခွဲမှုပေါ်တွင် တောင်းဆိုမှုကို ဆက်လက်မည်သည့်အခါ ငြင်းဆန်သည်သော်လည်း အဆင့်မြှင့်တင်မှုပြီးပါ - တုံ့ပြန်မှုတွင် လိုအပ်သည့် စီမံခန့်ခွဲမှုကိုအကြောင်းပြည့်ဝစေသည့် Upgrade ခေါင်းစဉ်ပါရှိသည်။

RFC 9110 ↗
428

အခြေအနေ လိုအပ်သည်

ဆာဗာသည် တောင်းဆိုမှုအခြေအနေကျ ဖြစ်သည်ကိုလိုအပ်သည်။

ဆာဗာသည် အခြေအနေကျ ခေါင်းစဉ်များ (If-Match ကဲ့သို့သော) ကို အဘယ်တွင် ပျက်ကွက်ခွင့် ပဋ္ဌBolton များပြားမှုကို ကာကွယ်ရန်လိုအပ်သည်။ အရင်းအမြစ်ကို အားထုတ်ခြင်း၊ သိုလည်း ETag အဖတ်ခြင်း၊ If-Match ဖြင့် ထပ်မံပို့ဆောင်ခြင်း။

RFC 6585 ↗
429

အများအပြားအားလုံးမိုးများ

ကလိုင်းသည် နံပါတ်သတ်မှတ်မှုမှ လုံခြုံခြင်းခံထားသည်။

ထဲမှုချုပ်။ တုံ့ပြန်မှုတွင် အသည်နံပါတ်နိုက်သည့်အခါ Retry-After ခေါင်းစဉ်ပါရှိသည်။ တောင်းဆိုမှုအကျ်မျ်ကမ်းက်ရှိသည့် APIs ဖြင့် ပုံမှန်ဖြစ်သည်။

RFC 6585 ↗
431

တောင်းဆိုမှု ခေါင်းစဉ် အကွက် အလွန်ကြီးမားသည်

ခေါင်းစဉ်များသည် ဆာဗာမှ ဖန်တီးမည်ရန် အလွန်အများ။

ခေါင်းစဉ်တစ်ခုသို့မဟုတ် စုစုပေါင်းခေါင်းစဉ်အရွယ်အစားသည် ကန့်သတ်မှုကျော်လွန်သည် - အများဆုံးအားဖြင့် အလွန်အများစုရှိသည့် ကွင်းများကြောင့်။ ကွင်းများကိုရှင်းထုတ်ခြင်း သို့မဟုတ် အပ်သည့် အောက်တွင် သိုလည်းထည့်သွင်းခြင်းကိုလျှော့ခြင်း။

RFC 6585 ↗
451

အတရားဆိုင်ရာ အကြောင်းအရာများအတွက် မရနိုင်သည်

အတရားဆိုင်ရာ အပ်များကြောင့် အခွင့်အရေး ငြင်းဆန်သည်။

ဥပဒေရေးရာအကြောင်းများကြောင့် အရင်းအမြစ်ကို ပိတ်ပင်ထားသည် — ဆင်ဆာဖြတ်ခြင်း၊ တရားရုံးအမိန့်များ သို့မဟုတ် ဒေသဆိုင်ရာ စည်းမျဉ်းများ။ ထိုနံပါတ်သည် Fahrenheit 451 ဝတ္ထုကို ရည်ညွှန်းသည်။

RFC 7725 ↗
500

ဆာဗာ အတွင်း အမှားအယွင်း

ဆာဗာသည် မျှော်မှန်းထားခြင်း မည်သည့်အခြင်းအရင်းကိုဆန်သည်။

ဆာဗာအခြင်းအရင်း အမှားအယွင်းများအတွက် ယေဘုယျ အုပ်ငွေ။ ဆာဗာ မှတ်သားမှုများအတွက် စစ်ဆေးခြင်း - ကိုင်တွယ်ထားမည်မဟုတ်သည့် အပမ်း၊ ဒေတာဘေ စ အမှားအယွင်းစသည်ဖြင့်။

RFC 9110 ↗
501

မည်သည့် အရာများကိုလည်း တည်ဆောက်မထားသည်

ဆာဗာသည် တောင်းဆိုမှုပြီး အလုပ်လုပ်ရည်မှာထည့်သွင်းမည်မဟုတ်။

ဥပမာ ဆာဗာသည် HTTP method ကို မသိခြင်း။ လက်တွေ့တွင် ရှားပါးသည် — ၄၀၅ ကို ပိုမြင်ရလေ့ရှိသည်။

RFC 9110 ↗
502

Gateway မှားမွားသည်

ဆာဗာသည် gateway အဖြစ်လုပ်ဆောင်သည့် အခါ upstream ဆာဗာမှ မှားမွားသည့် တုံ့ပြန်မှုကိုရယူခဲ့သည်။

microservice ကွဲခွဲမှုများတွင် ပုံမှန်ဖြစ်သည်။ လုံးချင်း အင်္ဂါရပ် သို့မဟုတ် reverse proxy သည် backend ဝန်ဆောင်မှုမှ မှားမွားသည့် တုံ့ပြန်မှုကိုရယူခဲ့သည်။

RFC 9110 ↗
503

ဝန်ဆောင်မှု မရနိုင်သည်

ဆာဗာသည် အခါတစ်ခါ တောင်းဆိုမှုကို ကိုင်တွယ်မည်မဟုတ်။

အဖြုန်းအစားအတွက် သို့မဟုတ် အလုံးအစုမများ။ တုံ့ပြန်မှုတွင် Retry-After ခေါင်းစဉ်ပါရှိသည်။ အများအားဖြင့် အဆင့်မြှင့်တင်မှုအလုံးအစုအခါတွင် ပြန်လည်ပြည့်ဝစေသည်။

RFC 9110 ↗
504

Gateway အချိန်ကုန်

gateway ဆာဗာသည် upstream တုံ့ပြန်မှုအတွက် စောင့်ဆိုင်းချိန်ကုန်သည်။

backend ဝန်ဆောင်မှုသည် အလုံးအစုအကျင့်မြန်မြန်ရုံ မည်သည့်အခါမျ။ upstream ဝန်ဆောင်မှု ကျေးဇူးတည်ခြင်း အချိန် အပ်လုပ်ဆောင်မှု ကွဲခွဲမှုများကိုစစ်ဆေးပါ။

RFC 9110 ↗
505

HTTP အဆင့် မလုပ်ဆောင်သည်

ဆာဗာသည် တောင်းဆိုမှုတွင် အသုံးပြုထားသည့် HTTP အဆင့်များကို လုပ်ဆောင်မည်မဟုတ်။

တောင်းဆိုမှု၏ အဓိကHTTP အဆင့်သည် ဆာဗာမှ အလျား မပြုလုပ်သည်။ ခေတ်သစ် ကလိုင်းများဖြင့် မည်သည့် အခြင်းအရင်းမျေးတို့ကို စုံစမ်းရသည်။

RFC 9110 ↗
506

အကွက်တည်ဆောင်း ကျင့်ဝတ်များကယ်လုံခြုံသည်

ဆာဗာသည် အကြောင်းအရာ ကျင့်ဝတ် မည်သည့် အမှားအယွင်းများ။

အလင်္ကာ အကြောင်းအရာ ကျင့်ဝတ်များသည် လုံးပတ်ခြင်းတွင် အဆုံးသတ်သည် - ရွေးချယ်ခြင်း အကွက်သည် ကျင့်ဝတ်များ မည်သည့် နည်းလမ်းကျင့်ဝတ်များအတွက်။ ဆာဗာ ကွဲခွဲမှု အမှားအယွင်းကိုညွှန်ပြသည်။

RFC 2295 ↗
507

သိုလည်းခြင်း မလုံလောက်သည်

ဆာဗာသည် ဒစ်စခ် အာကာသမှ ပြည်သူလူထုခြင်း။

WebDAV-အပ်သည့် အစောဖြစ်သည် သို့မဟုတ် အချို့ သည့်ပြည့်ဝခြင်း ဆာဗာများ။ ဆာဗာမှ သိုလည်းခြင်း အကန့်အသတ်များကြောင့် တောင်းဆိုမှုကိုသိုလည်းမည်မဟုတ်ဆိုသည်။

RFC 4918 ↗
508

လုံးပတ် စုံစမ်းခြင်း

ဆာဗာသည် တောင်းဆိုမှု လုပ်ဆောင်ခြင်း အခါ အဆုံးမျ်ကမ်း လုံးပတ်ခြင်းကို စုံစမ်းခြင်း။

WebDAV - Depth: အဆုံးမျ်ကမ်း တောင်းဆိုမှုလုပ်ဆောင်ခြင်း အလုံးအစုလုံးပတ်ခြင်း (ဥပမာ - စက်ဆန်ဒ ချုပ်တွင်း)။ အလုပ်မည်သည့် အခါတွင် အဆုံးသတ်သည်။

RFC 5842 ↗
510

အခြင်းအရင်း မည်သည့် အရာများ မထည့်သွင်းသည်

တောင်းဆိုမှုအပြည့်ချင်း အခြင်းအရင်း မည်သည့် လုပ်ဆောင်မှုများ လိုအပ်သည်။

အဆုံးသတ်လုပ်ဆောင်ထားသည့် HTTP Extension Framework မှ - ဆာဗာသည် တောင်းဆိုမှုကို ဖြည့်ဝရန် အစောတင် အချက်အလက်သည့်။ ခေတ်သစ် ကွန်ယက် အပေါ်တွင် လုံးဝ မည်သည့် အခြင်းအရင်းမျေးတို့ကို အသုံးမပြုသည်။

RFC 2774 ↗
511

ကွန်ယက် အခွင့်အရေး လိုအပ်သည်

ကလိုင်းသည် ကွန်ယက် အသုံးပြုခွင့်စိတ် ရယူရမည်။

အဖမ်းချုပ် အဆင့်များ (အခန်းခွင့် WiFi) မှ အသုံးပြုခြင်း - အသုံးပြုသူသည် ပြင်ပ ဆိုက်များမှ အသုံးပြုခွင့်စိတ် သည့် နှင့် ကွန်ယက် အလျောက်ရုံးဝင် ပြုလုပ်ရမည်ကိုညွှန်ပြသည်။

RFC 6585 ↗

အသုံးများသော အသုံးပြုမှုများ

  • API ဒီဇိုင်းအတွက် ကိုးကားချက်REST API များကို ဒီဇိုင်းဆွဲသည့်အခါ တုံ့ပြန်မှုတစ်ခုစီအတွက် သင့်လျော်သော status code ကို ရွေးချယ်ပါ။
  • Error Code များကို အမြန်ရှာဖွေပါသင့်အက်ပ်က ရှုပ်ထွေးသော HTTP error ပြန်လာသည့်အခါ တကယ်အဓိပ္ပာယ်ကို ရှာကြည့်ပါ။
  • HTTP Status Code များကို လေ့လာပါHTTP နှင့် REST ကို လေ့လာနေသော ကျောင်းသားများနှင့် developer များအတွက် ပြည့်စုံသော ကိုးကားချက်။
  • အဖြစ်အပျက်ကာလအတွင်း အမြန်ကိုးကားချက်production အဖြစ်အပျက်များအတွင်း status code တစ်ခုစီ၏ အဓိပ္ပာယ်ကို အမြန်ရှာကြည့်ပါ။
  • API မှတ်တမ်းများအတွက် ရည်ညွှန်းချက်API မှတ်တမ်းများရေးသားသည့်အခါ သင်ပြန်ထည့်သွင်းသည့် အခြေအနေလုံးဒီများ၏ အခွင့်အရေး ရွှေ့ပြောင်းမှုများသို့ လင်ခ်ပေးပါ။

မည်သို့ အလုပ်လုပ်သည်

ဤကိရိယာသည် class ငါးမျိုးစလုံး (1xx–5xx) ကျယ်ပြန့်စွာ ဖုံးလွှမ်းသော HTTP status code 63 ခု၏ ကိန်းသေ lookup table ပတ်ပတ်လည် တည်ဆောက်ထားသော client-side ကိုးကားချက်တစ်ခုဖြစ်သည်၊ code တစ်ခုစီကို ၎င်းသတ်မှတ်ထားသော RFC နံပါတ်ဖြင့် မှတ်ချက်ချထားသည်။ Server call၊ ပြင်ပ API၊ network request မပါဝင်ပါ — filter နှင့် ပြသမှုအားလုံးကို JavaScript ၏ built-in array နှင့် string method များကို သုံး၍ browser ထဲတွင် လုပ်ဆောင်သည်။

  1. 1
    Lookup table ကို load လုပ်ထားသည်
    IANA-registered status code 63 ခုအားလုံးကို JavaScript array တစ်ခုအဖြစ် ဤကိရိယာထဲသို့ တိုက်ရိုက် ထည့်သွင်းထားသည်၊ entry တစ်ခုစီတွင် ဂဏန်းကုဒ်၊ canonical အင်္ဂလိပ်အမည်၊ category class နှင့် ၎င်းကို သတ်မှတ်ထားသော RFC (ဥပမာ HTTP/1.1 code အများစုအတွက် RFC 9110၊ 429 Too Many Requests အတွက် RFC 6585၊ 418 I'm a Teapot အတွက် RFC 2324) ပါဝင်သည်။
  2. 2
    Filter ကို memory ထဲတွင် လုပ်ဆောင်သည်
    ရိုက်နေစဉ် (သို့) category filter ရွေးချယ်နေစဉ် JavaScript ၏ Array.filter သည် memory ထဲရှိ list ပေါ်တွင် လုပ်ဆောင်ပြီး String.includes ကို သုံး၍ သင့် query ကို status code နံပါတ်၊ canonical အမည်နှင့် ဖော်ပြချက် string တိုနှင့် ရှည် နှစ်မျိုးစလုံးနှင့် ကိုက်ညီစစ်ဆေးသည် — debounce ကြန့်ကြာချိန်၊ server round-trip မလိုအပ်ပါ။
  3. 3
    RFC link ပါသော အသေးစိတ်ချက် ချဲ့ထုတ်ထားသည်
    ရလဒ်တစ်ခုစီကို HTML details/summary element တစ်ခုအဖြစ် render လုပ်သည်။ Entry တစ်ခုကို ချဲ့ခြင်းသည် long-form ရှင်းလင်းချက်နှင့် rfc-editor.org ရှိ authoritative RFC သို့ direct link တစ်ခု ဖော်ပြသည်၊ ထို့ကြောင့် code မည်သည့်တစ်ခုအတွက်မဆို spec စာသားအတိအကျကို ဖတ်နိုင်သည်။
  4. 4
    Deep link နှင့် clipboard copy
    Entry တစ်ခုကို ဖွင့်ခြင်းသည် URL hash ကို code နံပါတ် (ဥပမာ #404) သို့ update လုပ်သည်၊ စာမျက်နှာကို မျှဝေနိုင်ပြီး bookmark-friendly ဖြစ်စေသည်။ Copy ခလုတ်သည် canonical string (ဥပမာ '404 Not Found') ကို browser ၏ navigator.clipboard API မှတစ်ဆင့် clipboard သို့ ရေးသည်။

ဆက်နွှယ်သော ကိရိယာများ

📚

ကိုးကားခြင်းဖန်တီးခြင်း

ဝဘ်ဆိုက်၊ စာအုပ်၊ ဂျာနယ်နှင့် YouTube များအတွက် APA 7၊ MLA 9၊ Chicago နှင့် Harvard ကိုးကားချက်များနှင့် စာသားအတွင်း ကိုးကားချက်များ ဖန်တီးပါ — ကူးယူရန် သို့မဟုတ် ထုတ်ယူရန် ကိုးကားစာရင်းလည်း တည်ဆောက်ပါ။ အခမဲ့ဖြစ်ပြီး ကိုယ်ရေးလုံခြုံသည်။

ကြိုးစားပါ
⏱️

အင်တာဗယ်အချိန်မှတ်စက်

အပူပေးခြင်း၊ ပတ်များ၊ ဆက်များ၊ ကြီးမားသော နောက်ပြန်ရေတွက်ခြင်း၊ အရောင်ခွဲထားသော အဆင့်များ၊ ဘီပ်အသံများနှင့် ရွေးချယ်နိုင်သော အသံညွှန်ကြားချက်များပါရှိသည့် HIIT နှင့် Tabata လေ့ကျင့်ခန်းများအတွက် အလုပ်နှင့်အနားယူချိန်မှတ်စက်။

ကြိုးစားပါ
🔪

ဗီဒီယို ခွဲကိရိယာ

ဗီဒီယိုရှည်ကို အပိုင်းများအဖြစ် ခွဲပါ- WhatsApp Status သို့မဟုတ် Stories အတွက် ၆၀ စက္ကန့် အပိုင်းများ၊ တူညီသော အပိုင်းအရေအတွက်၊ သို့မဟုတ် အီးမေးလ်အတွက် 25 MB ကဲ့သို့ အရွယ်အစားအောက် အပိုင်းများ။ အပိုင်းတစ်ခုချင်း သို့မဟုတ် အားလုံးကို ZIP အဖြစ် သိမ်းနိုင်သည်။ သင့် browser ထဲတွင် အလုပ်လုပ်သည်; ဗီဒီယိုကို အပ်လုဒ်မလုပ်ပါ။

ကြိုးစားပါဖိုင်များ ဒေသတွင်း ကျန်ရှိသည်

မကြာခဏ မေးလေ့မေးထရှိသော မေးခွန်းများ