ข้ามไปยังเนื้อหาหลัก

อ้างอิง HTTP Status Code ฟรี

อ้างอิงที่ค้นหาได้สำหรับ HTTP status code ทั้งหมด — ความหมายแต่ละรหัส การใช้งาน และสาเหตุทั่วไป ตั้งแต่ 100 ถึง 511

ใช้งานได้แบบออฟไลน์เมื่อโหลดแล้ว

61 รหัสสถานะ

100

ต่อไป

เซิร์ฟเวอร์ได้รับส่วนหัวของคำขอแล้ว ไคลเอนต์ควรดำเนินการต่อด้วยเนื้อหา

ใช้สำหรับคำขอที่มี Expect: 100-continue เซิร์ฟเวอร์ยอมรับว่าพร้อมจะรับเนื้อหาก่อนที่ไคลเอนต์จะส่ง ไม่ค่อยเห็นในแอพเว็บสมัยใหม่

RFC 9110 ↗
101

สลับโปรโตคอล

เซิร์ฟเวอร์กำลังสลับโปรโตคอลตามที่ไคลเอนต์ร้องขอ

ใช้บ่อยที่สุดสำหรับการอัปเกรด WebSocket — ไคลเอนต์ร้องขอ Upgrade: websocket และเซิร์ฟเวอร์ตอบกลับด้วย 101 เพื่อสลับ

RFC 9110 ↗
102

กำลังประมวลผล

เซิร์ฟเวอร์ได้รับคำขอและกำลังประมวลผล แต่ยังไม่มีการตอบสนอง

การตอบสนองชั่วคราว WebDAV ที่ส่งเพื่อป้องกันการหมดเวลาของไคลเอนต์ระหว่างการดำเนินการที่นาน เลิกใช้แล้ว — เซิร์ฟเวอร์สมัยใหม่ไม่ควรส่ง

RFC 2518 ↗
103

คำแนะนำเบื้องต้น

ส่วนหัวเบื้องต้นที่ส่งมาก่อนการตอบสนองสุดท้าย

ให้เซิร์ฟเวอร์ส่งส่วนหัว Link (preload/preconnect) ในขณะที่กำลังเตรียมการตอบสนองสุดท้าย เพื่อให้เบราว์เซอร์เริ่มดึงสินทรัพย์ที่สำคัญได้เร็วขึ้น

RFC 8297 ↗
200

ตกลง

คำขอสำเร็จแล้ว

การตอบสนองความสำเร็จมาตรฐาน ความหมายขึ้นอยู่กับวิธี HTTP: GET → ทรัพยากรที่ส่งกลับ POST/PUT → การดำเนินการเสร็จสิ้น

RFC 9110 ↗
201

สร้างแล้ว

ทรัพยากรใหม่ถูกสร้างขึ้นสำเร็จ

ทั่วไปหลังจาก POST การตอบสนองควรรวมส่วนหัว Location ที่ชี้ไปที่ URL ของทรัพยากรใหม่

RFC 9110 ↗
202

ยอมรับแล้ว

คำขอได้รับการยอมรับสำหรับการประมวลผล แต่ยังไม่เสร็จ

สำหรับการดำเนินการแบบอะซิงโครนัส — เซิร์ฟเวอร์กำลังจัดคิวการทำงาน ไคลเอนต์ควรโพล endpoint สถานะหรือตรวจสอบภายหลัง

RFC 9110 ↗
203

ข้อมูลที่ไม่ใช่ต้นฉบับ

การตอบสนองได้ถูกแก้ไขโดยพร็อกซีแปลง

คำขอสำเร็จ แต่ตัวกลาง (เช่น แคช หรือพร็อกซีแปลง) ได้เปลี่ยนแปลงข้อมูล จากเซิร์ฟเวอร์ต้นทาง — ตัวอย่างเช่น การบีบอัดภาพใหม่ หายากในทางปฏิบัติ

RFC 9110 ↗
204

ไม่มีเนื้อหา

คำขอสำเร็จ แต่ไม่มีเนื้อหาการตอบสนอง

มักใช้สำหรับการดำเนินการ DELETE หรือการอัปเดต PUT ที่ไม่จำเป็นต้องส่งคืนเนื้อหา ไคลเอนต์ไม่ควรนำทางออกจากหน้าปัจจุบัน

RFC 9110 ↗
205

รีเซ็ตเนื้อหา

คำขอสำเร็จ ไคลเอนต์ควรรีเซ็ตมุมมองเอกสาร

เช่นเดียวกับ 204 ไม่มีเนื้อหาที่ส่งคืน — แต่ไคลเอนต์ยังได้รับการบอกให้รีเซ็ตแบบฟอร์มหรือมุมมองที่สร้างคำขอ (เช่น ล้างช่องแบบฟอร์มสำหรับรายการถัดไป)

RFC 9110 ↗
206

เนื้อหาบางส่วน

เซิร์ฟเวอร์ส่งเฉพาะส่วนหนึ่งของทรัพยากร

การตอบสนองต่อคำขอ Range ใช้โดยเครื่องเล่นวิดีโอและตัวจัดการดาวน์โหลดเพื่อดาวน์โหลดต่อจากที่ค้างไว้หรือสตรีมไฟล์ขนาดใหญ่

RFC 9110 ↗
207

สถานะหลายอย่าง

เนื้อหาการตอบสนองมีรหัสสถานะหลายอย่างสำหรับการดำเนินการหลายอย่าง

WebDAV: เนื้อหา XML รายงานผลลัพธ์ของการดำเนินการย่อยหลายอย่างอย่างอิสระ — เช่น การย้ายแบบชุดที่การย้ายบางรายการสำเร็จและอื่น ๆ ล้มเหลว

RFC 4918 ↗
208

รายงานแล้ว

สมาชิกของคอลเลกชันถูกแสดงรายชื่อแล้วในการตอบสนองก่อนหน้า

WebDAV: ใช้ภายในการตอบสนอง 207 Multi-Status เพื่อหลีกเลี่ยงการแสดงรายชื่อสมาชิกของคอลเลกชันเดียวกันซ้ำ ๆ เมื่อการผูกมัดสร้างลูป

RFC 5842 ↗
226

ใช้ IM

การตอบสนองเป็นผลมาจากการจัดการอินสแตนซ์ที่นำไปใช้กับทรัพยากร

การเข้ารหัส Delta: เซิร์ฟเวอร์ส่งความแตกต่างจากเวอร์ชันก่อนหน้าแทนทรัพยากรทั้งหมด ประหยัดแบนด์วิดท์ แทบไม่มีการนำไปใช้

RFC 3229 ↗
300

ตัวเลือกหลายตัว

มีรูปแบบการแสดงของทรัพยากรให้เลือกหลายรูปแบบ

เซิร์ฟเวอร์นำเสนอตัวเลือกหลายตัว (เช่น รูปแบบหรือภาษาที่แตกต่างกัน) และไคลเอนต์ควรเลือกตัวเลือก หายากในการใช้งาน เนื่องจากการเจรจาเนื้อหาอัตโนมัติมักจะจัดการสิ่งนี้

RFC 9110 ↗
301

ย้ายถาวร

ทรัพยากรย้ายไปยัง URL ใหม่อย่างถาวร

ใช้สำหรับการเปลี่ยนแปลง URL ถาวร — เครื่องมือค้นหาจะอัปเดตดัชนีของพวกเขา SEO authority ถูกโอนไปยัง URL ใหม่

RFC 9110 ↗
302

พบ (การเปลี่ยนเส้นทางชั่วคราว)

ทรัพยากรอยู่ที่ URL อื่นชั่วคราว

ระบุว่าการเปลี่ยนเส้นทางไม่ถาวร แคชจะน้อยกว่า 301 ใช้สำหรับสิ่งต่างๆ เช่น 'ต้องมีการเข้าสู่ระบบ กำลังเปลี่ยนเส้นทางไปยัง /login'

RFC 9110 ↗
303

ดูที่อื่น

เปลี่ยนเส้นทางไปยัง URL อื่นโดยใช้ GET

ใช้หลังจากการส่งแบบฟอร์ม POST — การตอบสนองบอกว่า 'POST ของคุณสำเร็จ ดูผลลัพธ์ที่ GET URL นี้' เบราว์เซอร์จะ GET URL ใหม่เสมอ

RFC 9110 ↗
304

ไม่มีการแก้ไข

เวอร์ชันที่แคชไว้ยังใช้ได้ ให้ใช้เวอร์ชันนั้น

การตอบสนองต่อคำขออย่างมีเงื่อนไข (ด้วยส่วนหัว If-None-Match หรือ If-Modified-Since) ประหยัดแบนด์วิดท์ — ไม่มีการส่งคืนเนื้อหา

RFC 9110 ↗
307

การเปลี่ยนเส้นทางชั่วคราว

เช่น 302 แต่รักษาวิธี HTTP ดั้งเดิม

ถ้าของเดิมคือ POST การเปลี่ยนเส้นทางก็ใช้ POST ด้วย ทางเลือกสมัยใหม่ของ 302 เมื่อการรักษาวิธีสำคัญ

RFC 9110 ↗
308

การเปลี่ยนเส้นทางถาวร

เช่น 301 แต่รักษาวิธี HTTP ดั้งเดิม

การแทนที่สมัยใหม่สำหรับ 301 เมื่อคุณต้องการให้คำขอ POST ยังคงเป็น POST หลังจากการเปลี่ยนเส้นทาง

RFC 9110 ↗
400

คำขอไม่ถูกต้อง

เซิร์ฟเวอร์ไม่สามารถเข้าใจคำขอเนื่องจากไวยากรณ์ที่ไม่ถูกต้อง

สาเหตุทั่วไป: JSON ที่ไม่ถูกต้องในเนื้อหา พารามิเตอร์การค้นหาที่ไม่ถูกต้อง หรือช่องที่จำเป็นขาดหายไป ตรวจสอบเนื้อหาและส่วนหัวของคำขอ

RFC 9110 ↗
401

ไม่ได้รับอนุญาต

จำเป็นต้องพิสูจน์ตัวตน และยังไม่ได้ให้ข้อมูล

ไคลเอนต์ต้องแนบข้อมูลประจำตัว (ส่วนหัว Authorization คุกกี้ โทเค็น) 'Unauthorized' เป็นชื่อที่เรียกคลาดเคลื่อน — จริง ๆ แล้วหมายถึง 'ยังไม่ได้พิสูจน์ตัวตน'

RFC 9110 ↗
402

ต้องชำระเงิน

สงวนไว้สำหรับการใช้งานในอนาคต — บางครั้งใช้สำหรับระดับ API ที่จ่ายเงิน

เดิมมีวัตถุประสงค์เพื่อการชำระเงินดิจิทัล การใช้งานสมัยใหม่: API บางครั้งส่งกลับ 402 เมื่อผู้ใช้เกินโควตาการชำระเงิน

RFC 9110 ↗
403

ถูกห้ามเข้าถึง

ไคลเอนต์พิสูจน์ตัวตนแล้ว แต่ไม่มีสิทธิ์

แตกต่างจาก 401 — ผู้ใช้เข้าสู่ระบบแล้ว แต่บัญชีของพวกเขาไม่มีสิทธิ์สำหรับทรัพยากรนี้ ตรวจสอบตรรกะบทบาท/สิทธิ์

RFC 9110 ↗
404

ไม่พบ

ทรัพยากรที่ร้องขอไม่มีอยู่

URL ไม่ถูกต้อง ทรัพยากรถูกลบ หรือไม่เคยมีอยู่มาก่อน เซิร์ฟเวอร์บางครั้งส่งกลับ 404 เพื่อซ่อนว่า 403 จะแม่นยำมากกว่า

RFC 9110 ↗
405

วิธีการไม่ได้รับอนุญาต

วิธี HTTP ที่ใช้ไม่ได้รับการอนุญาตสำหรับทรัพยากรนี้

ตัวอย่างเช่น คำขอ GET ไปยัง endpoint ที่ยอมรับเฉพาะ POST การตอบสนองควรรวมส่วนหัว Allow ที่แสดงรายวิธีที่ถูกต้อง

RFC 9110 ↗
406

ไม่ยอมรับ

ไม่มีตัวแทนที่ตรงกับส่วนหัว Accept ของไคลเอนต์

ไคลเอนต์ขอประเภทเนื้อหา ภาษา หรือการเข้ารหัส (ผ่าน Accept Accept-Language Accept-Encoding) ที่เซิร์ฟเวอร์ไม่สามารถตอบสนองได้ เซิร์ฟเวอร์จำนวนมากข้ามการเจรจาที่เข้มงวดและส่งกลับค่าเริ่มต้น

RFC 9110 ↗
407

ต้องพิสูจน์ตัวตนกับพร็อกซี

ไคลเอ็นต์ต้องตรวจสอบสิทธิ์กับพร็อกซีก่อน

เช่นเดียวกับ 401 แต่ออกโดยพร็อกซี: ไคลเอนต์ต้องส่งข้อมูลประจำตัว Proxy-Authorization พบบนเครือข่ายองค์กรที่มีพร็อกซีพิสูจน์ตัวตน

RFC 9110 ↗
408

Request Timeout

เซิร์ฟเวอร์หมดเวลาขณะรอคำขอ

ไคลเอ็นต์ใช้เวลานานเกินไปในการส่งบอดี้ของคำขอหรือเก็บการเชื่อมต่อไว้เฉยๆ ลองส่งคำขออีกครั้ง

RFC 9110 ↗
409

Conflict

คำขอขัดแย้งกับสถานะปัจจุบันของทรัพยากร

มักจะส่งกลับสำหรับความขัดแย้งในการแก้ไขพร้อมกันหรือการสร้างทรัพยากรที่ซ้ำกัน (เช่น การสร้างผู้ใช้ด้วยอีเมลที่มีอยู่แล้ว)

RFC 9110 ↗
410

Gone

ทรัพยากรถูกลบและจะไม่กลับมา

รุนแรงกว่า 404 — เซิร์ฟเวอร์รู้อย่างชัดเจนว่าทรัพยากรเคยมีอยู่แต่ถูกลบออกอย่างถาวรแล้ว เสิร์ชเอนจินจะลบออกจากดัชนี

RFC 9110 ↗
411

Length Required

เซิร์ฟเวอร์ต้องการหัว Content-Length

คำขอถูกปฏิเสธเพราะหัว Content-Length หายไปและเซิร์ฟเวอร์ปฏิเสธบอดี้ที่ไม่ทราบขนาด เพิ่มหัวและลองใหม่

RFC 9110 ↗
412

Precondition Failed

เงื่อนไขในหัวคำขอไม่เป็นไปตามที่กำหนด

ส่งกลับเมื่อหัวแบบมีเงื่อนไขเช่น If-Match หรือ If-Unmodified-Since ล้มเหลว — มักเป็นการล็อกแบบ optimistic: มีคนอื่นแก้ไขทรัพยากรหลังจากเวอร์ชันของคุณ ดึงข้อมูลใหม่และลองอีกครั้ง

RFC 9110 ↗
413

Payload Too Large

บอดี้ของคำขอเกินขีดจำกัดขนาดของเซิร์ฟเวอร์

เกิดขึ้นบ่อยครั้งเมื่ออัปโหลดไฟล์ขนาดใหญ่ การตั้งค่าเซิร์ฟเวอร์ (nginx, apache) กำหนดขนาดบอดี้สูงสุด ตรวจสอบการตั้งค่าเซิร์ฟเวอร์

RFC 9110 ↗
414

URI Too Long

URL ของคำขอเกินขีดจำกัดความยาวของเซิร์ฟเวอร์

มักเกิดจากสตริงค้นหายาวมากๆ (เช่น การเข้ารหัสข้อมูลใน GET) สลับไปเป็นบอดี้ POST หรือเพิ่มขีดจำกัดของเซิร์ฟเวอร์หากคุณควบคุมมัน

RFC 9110 ↗
415

Unsupported Media Type

เซิร์ฟเวอร์ไม่สามารถจัดการ Content-Type ที่ส่งมา

เช่น การส่ง application/xml ไปยังเซิร์ฟเวอร์ที่ยอมรับเฉพาะ application/json ตั้งหัว Content-Type ให้ถูกต้อง

RFC 9110 ↗
416

Range Not Satisfiable

ช่วงไบต์ที่ขอนอกขนาดของทรัพยากร

หัว Range ขอส่วนที่ไฟล์ไม่มี — เช่น การดาวน์โหลดต่อจากตำแหน่งที่เกินท้ายไฟล์ การตอบสนองควรรวม Content-Range ที่ระบุขนาดจริง

RFC 9110 ↗
417

Expectation Failed

เซิร์ฟเวอร์ไม่สามารถตอบสนองความต้องการของหัว Expect

ส่งเมื่อเซิร์ฟเวอร์ไม่รองรับ Expect: 100-continue ไคลเอ็นต์บางตัวส่งหัวนี้โดยค่าเริ่มต้นบน POST ขนาดใหญ่ การปิดใช้งานมักจะแก้ไขข้อผิดพลาด

RFC 9110 ↗
418

I'm a Teapot

เซิร์ฟเวอร์ปฏิเสธที่จะต้มกาแฟเพราะมันเป็นกาน้ำชา

เรื่องตลกวันเอพริลฟูลส์ปี 1998 (RFC 2324) API บางตัวใช้เป็นเรื่องตลกหรือทำเครื่องหมาย endpoint ที่เลิกใช้ ไม่ใช่สำหรับใช้งานจริง

RFC 2324 ↗
421

Misdirected Request

คำขอถูกส่งไปยังเซิร์ฟเวอร์ที่ไม่สามารถสร้างการตอบสนองได้

พบบ่อยเมื่อนำการเชื่อมต่อ HTTP/2 กลับมาใช้ซ้ำ: คำขอไปถึงเซิร์ฟเวอร์ที่ไม่ได้กำหนดค่าสำหรับชื่อโฮสต์เป้าหมาย ไคลเอ็นต์ควรลองใหม่บนการเชื่อมต่อใหม่

RFC 9110 ↗
422

Unprocessable Content

คำขอมีไวยากรณ์ถูกต้องแต่ความหมายผิด

เช่น JSON แยกวิเคราะห์อย่างถูกต้องแต่ช่องที่จำเป็นหายไปหรือค่าช่องนอกช่วง พบบ่อยในการตอบสนองการตรวจสอบ REST API

RFC 9110 ↗
423

Locked

ทรัพยากรถูกล็อค

WebDAV: ทรัพยากรต้นทางหรือปลายทางถูกล็อกโดยไคลเอ็นต์อื่น จึงไม่สามารถดำเนินการได้ รอให้ปลดล็อกหรือปลดล็อกด้วยโทเค็นที่ถูกต้อง

RFC 4918 ↗
424

Failed Dependency

คำขอล้มเหลวเพราะคำขอที่ขึ้นต่อกันก่อนหน้านี้ล้มเหลว

WebDAV: ในห่วงโซ่ของการดำเนินการที่ขึ้นต่อกัน การกระทำก่อนหน้านี้ล้มเหลว ดังนั้นจึงไม่ได้ทำการดำเนินการนี้ ดูความล้มเหลวก่อนหน้านี้เพื่อหาสาเหตุหลัก

RFC 4918 ↗
425

Too Early

เซิร์ฟเวอร์ปฏิเสธที่จะประมวลผลคำขอที่อาจถูกส่งซ้ำ

เกี่ยวข้องกับ TLS 1.3 0-RTT (early data): เซิร์ฟเวอร์จะไม่เสี่ยงประมวลผลคำขอที่อาจถูกส่งซ้ำ ไคลเอ็นต์ควรลองใหม่หลังจากแฮนด์เชคเสร็จสิ้น

RFC 8470 ↗
426

Upgrade Required

ไคลเอ็นต์ต้องสลับไปโปรโตคอลอื่น

เซิร์ฟเวอร์ปฏิเสธที่จะให้บริการคำขอผ่านโปรโตคอลปัจจุบัน แต่จะหลังจากอัปเกรด — การตอบสนองรวมหัว Upgrade ที่ตั้งชื่อโปรโตคอลที่ต้องการ

RFC 9110 ↗
428

Precondition Required

เซิร์ฟเวอร์ต้องการให้คำขอมีเงื่อนไข

เซิร์ฟเวอร์เรียกร้องหัวแบบมีเงื่อนไข (เช่น If-Match) เพื่อป้องกันความขัดแย้งของการปรับปรุงที่สูญหาย ดึงทรัพยากร จับ ETag ของมัน และส่งใหม่ด้วย If-Match

RFC 6585 ↗
429

Too Many Requests

ไคลเอ็นต์ถูกจำกัดอัตรา

ช้าลง การตอบสนองควรรวมหัว Retry-After ที่ระบุเวลาที่จะลองใหม่ พบบ่อยกับ API ที่มีโควตาคำขอ

RFC 6585 ↗
431

Request Header Fields Too Large

หัวใหญ่เกินไปสำหรับเซิร์ฟเวอร์ที่จะประมวลผล

หัวตัวใดตัวหนึ่งหรือขนาดหัวทั้งหมดเกินขีดจำกัด — มักเกิดจากคุกกี้ขนาดใหญ่ล้น ล้างคุกกี้หรือลดสิ่งที่แอปของคุณเก็บไว้ในนั้น

RFC 6585 ↗
451

Unavailable For Legal Reasons

การเข้าถึงถูกปฏิเสธเนื่องจากข้อเรียกร้องทางกฎหมาย

ทรัพยากรถูกบล็อกด้วยเหตุผลทางกฎหมาย — การเซนเซอร์ คำสั่งศาล หรือกฎระเบียบระดับภูมิภาค หมายเลขนี้เป็นการคารวะนวนิยายเรื่อง Fahrenheit 451

RFC 7725 ↗
500

Internal Server Error

เซิร์ฟเวอร์พบเงื่อนไขที่ไม่คาดคิด

ข้อผิดพลาดแบบครอบคลุมทั่วไปฝั่งเซิร์ฟเวอร์ ตรวจสอบบันทึกเซิร์ฟเวอร์เพื่อหาสาเหตุจริง: ข้อยกเว้นที่ไม่ได้จัดการ ข้อผิดพลาดของฐานข้อมูล เป็นต้น

RFC 9110 ↗
501

Not Implemented

เซิร์ฟเวอร์ไม่รองรับฟังก์ชันที่ขอ

เช่น เซิร์ฟเวอร์ไม่รู้จักเมธอด HTTP พบได้น้อยในทางปฏิบัติ — โดยทั่วไปคุณมักจะเจอ 405 มากกว่า

RFC 9110 ↗
502

Bad Gateway

เซิร์ฟเวอร์ซึ่งทำหน้าที่เป็นเกตเวย์ ได้รับการตอบสนองที่ไม่ดีจากเซิร์ฟเวอร์ต้นน้ำ

พบบ่อยในสถาปัตยกรรมไมโครเซอร์วิส ตัวสมดุลโหลดหรือพร็อกซีย้อนกลับของคุณได้รับการตอบสนองที่ผิดรูปแบบจากบริการแบ็กเอนด์

RFC 9110 ↗
503

Service Unavailable

เซิร์ฟเวอร์ไม่สามารถจัดการคำขอได้ชั่วคราว

อยู่ระหว่างปิดปรับปรุงหรือโอเวอร์โหลด การตอบสนองควรรวมหัว Retry-After มักส่งกลับในระหว่างการปรับใช้

RFC 9110 ↗
504

Gateway Timeout

เซิร์ฟเวอร์เกตเวย์หมดเวลาขณะรอการตอบสนองต้นน้ำ

บริการแบ็กเอนด์ไม่ตอบสนองเร็วพอ ตรวจสอบสถานะการทำงานของบริการต้นน้ำและการตั้งค่าหมดเวลา

RFC 9110 ↗
505

HTTP Version Not Supported

เซิร์ฟเวอร์ไม่รองรับเวอร์ชัน HTTP ที่ใช้ในคำขอ

หมายเลข HTTP เวอร์ชันหลักของคำขอไม่รองรับโดยเซิร์ฟเวอร์ ไม่เคยเห็นกับไคลเอ็นต์สมัยใหม่

RFC 9110 ↗
506

Variant Also Negotiates

การตั้งค่าการเจรจาเนื้อหาของเซิร์ฟเวอร์ไม่ถูกต้อง

การเจรจาเนื้อหาแบบโปร่งใส สิ้นสุดลงในลูป: ตัวแปรที่เลือกเองมีการตั้งค่าให้เจรจา บ่งชี้ถึงข้อผิดพลาดในการตั้งค่าเซิร์ฟเวอร์

RFC 2295 ↗
507

Insufficient Storage

เซิร์ฟเวอร์หมดพื้นที่ดิสก์

เดิมเป็นของ WebDAV โดยเฉพาะ แต่บางครั้งเซิร์ฟเวอร์ทั่วไปก็ใช้ หมายความว่าเซิร์ฟเวอร์ไม่สามารถบันทึกคำขอได้เนื่องจากข้อจำกัดด้านพื้นที่จัดเก็บ

RFC 4918 ↗
508

Loop Detected

เซิร์ฟเวอร์ตรวจพบลูปอนันต์ขณะประมวลผลคำขอ

WebDAV: การประมวลผลคำขอ Depth: infinity เข้าสู่ลูป (เช่น การเชื่อมโยงแบบวงกลม) การดำเนินการถูกยกเลิก

RFC 5842 ↗
510

Not Extended

จำเป็นต้องมีส่วนขยายเพิ่มเติมสำหรับคำขอ

จากเฟรมเวิร์ก HTTP Extension ที่ล้าสมัย: เซิร์ฟเวอร์ต้องการข้อมูลเพิ่มเติมก่อนที่จะตอบสนอง ไม่มีการใช้งานบนเว็บสมัยใหม่

RFC 2774 ↗
511

Network Authentication Required

ไคลเอ็นต์ต้องตรวจสอบสิทธิ์เพื่อเข้าถึงเครือข่าย

ใช้โดย captive portal (WiFi โรงแรม/สนามบิน) เพื่อระบุว่าผู้ใช้ต้องเข้าสู่ระบบเครือข่ายก่อนเข้าถึงไซต์ภายนอก

RFC 6585 ↗

การใช้งานทั่วไป

  • อ้างอิงสำหรับการออกแบบ APIเมื่อออกแบบ REST API ให้เลือกรหัสสถานะที่ถูกต้องสำหรับแต่ละการตอบสนอง
  • ค้นหารหัสข้อผิดพลาดอย่างรวดเร็วเมื่อแอปของคุณส่งกลับข้อผิดพลาด HTTP ที่สับสน ให้ค้นหาว่าหมายความว่าอะไร
  • เรียนรู้รหัสสถานะ HTTPอ้างอิงที่ครอบคลุมสำหรับนักเรียนและนักพัฒนาที่เรียนรู้ HTTP และ REST
  • อ้างอิงด่วนระหว่างเหตุการณ์ในระหว่างการเกิดเหตุการณ์ในการผลิต ให้ค้นหาอย่างรวดเร็วว่ารหัสสถานะแต่ละรหัสหมายถึงอะไร
  • อ้างอิงสำหรับเอกสาร APIเมื่อเขียนเอกสาร API ให้ลิงก์ไปยังคำอธิบายที่มีอำนาจเกี่ยวกับรหัสสถานะที่คุณส่งกลับ

วิธีการทำงาน

เครื่องมือนี้เป็นเอกสารอ้างอิงฝั่งไคลเอนต์ที่สร้างรอบตารางค้นหารหัสสถานะ HTTP 63 รหัสที่กำหนดไว้ ครอบคลุมทั้งห้าคลาส (1xx–5xx) แต่ละรหัสระบุหมายเลข RFC ที่กำหนด ไม่มีการเรียกเซิร์ฟเวอร์ ไม่มี API ภายนอก และไม่มีการร้องขอเครือข่าย — การกรองและแสดงผลทั้งหมดเกิดขึ้นในเบราว์เซอร์ด้วยเมธอดอาร์เรย์และสตริงในตัวของ JavaScript

  1. 1
    โหลดตารางค้นหา
    รหัสสถานะที่ลงทะเบียนกับ IANA ครบ 63 รหัสฝังอยู่ในเครื่องมือนี้โดยตรงเป็นอาร์เรย์ JavaScript แต่ละรายการมีรหัสตัวเลข ชื่อภาษาอังกฤษมาตรฐาน คลาสหมวดหมู่ และ RFC เฉพาะที่กำหนด (เช่น RFC 9110 สำหรับรหัส HTTP/1.1 ส่วนใหญ่ RFC 6585 สำหรับ 429 Too Many Requests RFC 2324 สำหรับ 418 I'm a Teapot)
  2. 2
    กรองในหน่วยความจำ
    ขณะพิมพ์หรือเลือกตัวกรองหมวดหมู่ Array.filter ของ JavaScript ทำงานกับรายการในหน่วยความจำ จับคู่คำค้นกับหมายเลขรหัสสถานะ ชื่อมาตรฐาน และสตริงคำอธิบายทั้งแบบสั้นและยาวด้วย String.includes — ไม่มีการหน่วง ไม่มีการเรียกเซิร์ฟเวอร์ไปกลับ
  3. 3
    ขยายรายละเอียดพร้อมลิงก์ RFC
    แต่ละผลลัพธ์แสดงเป็นองค์ประกอบ HTML details/summary การขยายรายการจะแสดงคำอธิบายแบบยาวและลิงก์ตรงไปยัง RFC ที่เป็นทางการบน rfc-editor.org คุณจึงอ่านข้อความข้อกำหนดที่แน่นอนของรหัสใดก็ได้
  4. 4
    ลิงก์ตรงและการคัดลอกไปยังคลิปบอร์ด
    การเปิดรายการจะอัปเดต hash ของ URL เป็นหมายเลขรหัส (เช่น #404) ทำให้หน้าแชร์และบุ๊กมาร์กได้ ปุ่มคัดลอกเขียนสตริงมาตรฐาน (เช่น '404 Not Found') ลงคลิปบอร์ดผ่าน navigator.clipboard API ของเบราว์เซอร์

เครื่องมือที่เกี่ยวข้อง

📚

เครื่องมือสร้างการอ้างอิง

สร้างการอ้างอิง APA 7, MLA 9, Chicago และ Harvard รวมถึงการอ้างอิงในเนื้อหาสำหรับเว็บไซต์ หนังสือ วารสาร และ YouTube และสร้างรายการอ้างอิงเพื่อคัดลอกหรือส่งออก ฟรีและเป็นส่วนตัว

ลองใช้
⏱️

ตัวจับเวลาแบบช่วง

ตัวจับเวลาทำงานและพักสำหรับการออกกำลังกายแบบ HIIT และ Tabata พร้อมช่วงวอร์มอัป รอบ เซ็ต ตัวเลขนับถอยหลังขนาดใหญ่ ช่วงที่แยกด้วยสี เสียงบี๊บ และเสียงพูดบอกที่เลือกเปิดได้

ลองใช้
🔪

ตัดแบ่งวิดีโอ

แบ่งวิดีโอยาวเป็นส่วนๆ: ท่อนละ 60 วินาทีสำหรับสถานะหรือสตอรี่ WhatsApp, แบ่งเป็นจำนวนส่วนเท่าๆ กัน หรือแบ่งให้แต่ละส่วนไม่เกินขนาดที่กำหนด เช่น 25 MB สำหรับส่งอีเมล บันทึกทีละส่วนหรือทั้งหมดเป็นไฟล์ ZIP ทำงานในเบราว์เซอร์ของคุณ ไม่มีการอัปโหลดวิดีโอ

ลองใช้ไฟล์อยู่ในเครื่อง

คำถามที่พบบ่อย