LibraTool logoLibraTool

இலவச HTTP நிலை குறியீடுகள் குறிப்பு

அனைத்து HTTP நிலை குறியீடுகளுக்கும் தேடக்கூடிய குறிப்பு — ஒவ்வொன்றின் பொருள், அது எப்போது பயன்படுத்தப்படுகிறது, மற்றும் பொதுவான காரணங்கள். 100 முதல் 511 வரை.

ஏற்றியப் பிறகு ஆஃப்லைனில் வேலை செய்கிறது

61 நிலை குறியீடுகள்

100

தொடர்

சர்வர் கோரிக்கை தலைப்புகளைப் பெற்றுள்ளது, கிளையன்ட் உள்ளடக்கத்துடன் தொடர வேண்டும்.

Expect: 100-continue உடன் கூடிய கோரிக்கைகளுக்கு பயன்படுத்தப்படுகிறது. கிளையன்ட் அதை அனுப்பும் முன் உள்ளடக்கத்தைப் பெற தயார் என்பதை சர்வர் உறுதிசெய்கிறது. நவீன வலை ஆப்களில் அரிதாகவே காணப்படும்.

RFC 9110 ↗
101

நெறிமுறைகளை மாற்றுதல்

கிளையன்ட் கோரியபடி சர்வர் நெறிமுறைகளை மாற்றுகிறது.

WebSocket மேம்படுத்தல்களுக்கு பொதுவாக பயன்படுத்தப்படுகிறது — கிளையன்ட் Upgrade: websocket-ஐ கோருகிறது, சர்வர் மாற்ற 101 உடன் பதிலளிக்கிறது.

RFC 9110 ↗
102

செயலாக்கம் நடைபெறுகிறது

சர்வர் கோரிக்கையைப் பெற்று செயலாக்குகிறது, ஆனால் இன்னும் எந்த பதிலும் கிடைக்கவில்லை.

நீண்ட செயல்பாடுகளின் போது கிளையன்ட் நேரம் முடிவதை தடுக்க அனுப்பப்படும் WebDAV இடைநிலை பதில். நிறுத்தப்பட்டது — நவீன சர்வர்கள் இதை அனுப்பக்கூடாது.

RFC 2518 ↗
103

ஆரம்ப குறிப்புகள்

இறுதி பதிலுக்கு முன் அனுப்பப்படும் முதற்கட்ட தலைப்புகள்.

இறுதி பதில் இன்னும் தயாராகிக் கொண்டிருக்கும்போது சர்வர்கள் Link தலைப்புகளை (preload/preconnect) அனுப்ப அனுமதிக்கிறது, இதனால் உலாவிகள் முக்கிய சொத்துக்களை விரைவில் பெற தொடங்க முடியும்.

RFC 8297 ↗
200

சரி

கோரிக்கை வெற்றி பெற்றது.

நிலையான வெற்றி பதில். பொருள் HTTP முறையைப் பொறுத்தது: GET → வளம் திரும்பப்பட்டது, POST/PUT → செயல் முடிந்தது.

RFC 9110 ↗
201

உருவாக்கப்பட்டது

புதிய வளம் வெற்றிகரமாக உருவாக்கப்பட்டது.

POST-க்குப் பிறகு பொதுவானது. பதிலில் புதிய வளத்தின் URL-ஐ சுட்டிக்காட்டும் Location தலைப்பு இருக்க வேண்டும்.

RFC 9110 ↗
202

ஏற்கப்பட்டது

கோரிக்கை செயலாக்கத்திற்காக ஏற்கப்பட்டது, ஆனால் செயலாக்கம் முடியவில்லை.

ஒத்திசைவற்ற செயல்பாடுகளுக்கு — சர்வர் வேலையை வரிசையில் வைக்கிறது. கிளையன்ட் ஒரு நிலை முனையத்தை கேட்க வேண்டும் அல்லது பின்னர் சரிபார்க்க வேண்டும்.

RFC 9110 ↗
203

அதிகாரப்பூர்வமற்ற தகவல்

பதில் ஒரு மாற்றும் ப்ராக்ஸியால் மாற்றப்பட்டது.

கோரிக்கை வெற்றி பெற்றது, ஆனால் ஒரு இடைத்தரகர் (எடுத்துக்காட்டாக கேஷிங் அல்லது மாற்றும் ப்ராக்ஸி) மூல சர்வரிலிருந்து பேலோடை மாற்றியது — எடுத்துக்காட்டாக, படங்களை மீண்டும் சுருக்குதல். நடைமுறையில் அரிதானது.

RFC 9110 ↗
204

உள்ளடக்கம் இல்லை

கோரிக்கை வெற்றி பெற்றது ஆனால் பதில் உள்ளடக்கம் இல்லை.

பொதுவாக DELETE செயல்பாடுகளுக்கு அல்லது உள்ளடக்கத்தை திருப்பி அனுப்ப வேண்டாத PUT புதுப்பிப்புகளுக்கு பயன்படுத்தப்படுகிறது. கிளையன்ட் தற்போதைய பக்கத்திலிருந்து விலகிச் செல்லக்கூடாது.

RFC 9110 ↗
205

உள்ளடக்கத்தை மீட்டமை

கோரிக்கை வெற்றி பெற்றது; கிளையன்ட் ஆவண காட்சியை மீட்டமைக்க வேண்டும்.

204 போலவே, உள்ளடக்கம் திரும்பப்படாது — ஆனால் கோரிக்கையை உருவாக்கிய படிவம் அல்லது காட்சியை மீட்டமைக்கவும் கிளையன்ட் கூடுதலாக அறிவுறுத்தப்படுகிறது (எடுத்துக்காட்டாக அடுத்த உள்ளீட்டிற்கு படிவ புலங்களை அழி).

RFC 9110 ↗
206

பகுதி உள்ளடக்கம்

சர்வர் வளத்தின் ஒரு பகுதியை மட்டுமே வழங்கியது.

Range கோரிக்கைக்கான பதில். இடைநிற்றல்பட்ட பதிவிறக்கங்களை மீண்டும் தொடங்க அல்லது பெரிய கோப்புகளை ஸ்ட்ரீம் செய்ய வீடியோ பிளேயர்கள் மற்றும் பதிவிறக்க மேலாளர்களால் பயன்படுத்தப்படுகிறது.

RFC 9110 ↗
207

பல-நிலை

பதில் உள்ளடக்கத்தில் பல செயல்பாடுகளுக்கான பல நிலைக் குறியீடுகள் உள்ளன.

WebDAV: ஒரு XML உள்ளடக்கம் பல துணை-செயல்பாடுகளின் முடிவை தனித்தனியாக அறிக்கை செய்கிறது — எடுத்துக்காட்டாக சில உருப்படிகள் வெற்றியடைந்து மற்றவை தோல்வியடைந்த தொகுதி நகர்வு.

RFC 4918 ↗
208

ஏற்கனவே தெரிவிக்கப்பட்டது

தொகுப்பின் உறுப்பினர்கள் பதிலில் ஏற்கனவே முன்பே பட்டியலிடப்பட்டனர்.

WebDAV: பைண்டிங்குகள் சுழற்சிகளை உருவாக்கும்போது ஒரே தொகுப்பின் உறுப்பினர்களை மீண்டும் மீண்டும் பட்டியலிடுவதைத் தவிர்க்க 207 Multi-Status பதில்களுக்குள் பயன்படுத்தப்படுகிறது.

RFC 5842 ↗
226

IM Used

இந்தப் பதில் வளத்திற்குப் பயன்படுத்தப்பட்ட instance manipulations-இன் முடிவாகும்.

Delta encoding: முழு வளத்திற்குப் பதிலாக சேவையகம் முந்தைய பதிப்புடன் ஒப்பிட்ட வேறுபாட்டைத் திருப்பி அனுப்புகிறது, இதனால் bandwidth மிச்சமாகிறது. மிகவும் அரிதாகவே செயல்படுத்தப்படுகிறது.

RFC 3229 ↗
300

பல தேர்வுகள்

வளத்தின் பல பிரதிநிதித்துவங்கள் கிடைக்கின்றன.

சேவையகம் பல விருப்பங்களை வழங்குகிறது (எ.கா. வெவ்வேறு வடிவங்கள் அல்லது மொழிகள்), கிளையன்ட் ஒன்றைத் தேர்ந்தெடுக்க வேண்டும். தானியங்கி content negotiation பொதுவாக இதைக் கையாளுவதால் அரிதாகவே பயன்படுத்தப்படுகிறது.

RFC 9110 ↗
301

நிரந்தரமாக நகர்த்தப்பட்டது

வளம் புதிய URL-க்கு நிரந்தரமாக நகர்த்தப்பட்டுள்ளது.

நிரந்தர URL மாற்றங்களுக்குப் பயன்படுத்தவும் — தேடுபொறிகள் தங்கள் index-ஐப் புதுப்பிக்கும். SEO authority புதிய URL-க்கு மாற்றப்படும்.

RFC 9110 ↗
302

கிடைத்தது (தற்காலிக திசைதிருப்பல்)

வளம் தற்காலிகமாக வேறு URL-இல் உள்ளது.

திசைதிருப்பல் நிரந்தரமானது அல்ல என்பதைக் குறிக்கிறது. 301-ஐ விட caching குறைவாக இருக்கும். 'உள்நுழைவு தேவை, /login-க்குத் திசைதிருப்பப்படுகிறது' போன்றவற்றிற்குப் பயன்படுத்தவும்.

RFC 9110 ↗
303

மற்றொன்றைப் பார்க்கவும்

GET பயன்படுத்தி வேறு URL-க்குத் திசைதிருப்பவும்.

POST சமர்ப்பிப்புகளுக்குப் பின் பயன்படுத்தப்படுகிறது — 'உங்கள் POST வேலை செய்தது, முடிவுக்கு இந்த GET URL-ஐப் பார்க்கவும்' என்று பதில் கூறுகிறது. உலாவிகள் எப்போதும் புதிய URL-ஐ GET செய்யும்.

RFC 9110 ↗
304

மாற்றப்படவில்லை

கேச் செய்யப்பட்ட பதிப்பு இன்னும் செல்லுபடியாகும்; அதைப் பயன்படுத்தவும்.

நிபந்தனை கோரிக்கைக்கான பதில் (If-None-Match அல்லது If-Modified-Since headers உடன்). bandwidth மிச்சமாகிறது — body எதுவும் திருப்பி அனுப்பப்படாது.

RFC 9110 ↗
307

தற்காலிக திசைதிருப்பல்

302 போலவே ஆனால் அசல் HTTP method-ஐப் பாதுகாக்கிறது.

அசல் POST எனில், திசைதிருப்பலும் POST-ஐப் பயன்படுத்தும். method-ஐப் பாதுகாக்க வேண்டியிருக்கும்போது 302-க்கான நவீன மாற்று.

RFC 9110 ↗
308

நிரந்தர திசைதிருப்பல்

301 போலவே ஆனால் அசல் HTTP method-ஐப் பாதுகாக்கிறது.

திசைதிருப்பலுக்குப் பின்னும் POST கோரிக்கைகள் POST-ஆகவே இருக்க வேண்டும் எனில், 301-க்கான நவீன மாற்று.

RFC 9110 ↗
400

தவறான கோரிக்கை

தவறான syntax காரணமாக சேவையகத்தால் கோரிக்கையைப் புரிந்துகொள்ள முடியவில்லை.

பொதுவான காரணங்கள்: body-இல் தவறான JSON, தவறான query அளவுருக்கள், அல்லது தேவையான புலங்கள் இல்லாதது. கோரிக்கை body மற்றும் headers-ஐச் சரிபார்க்கவும்.

RFC 9110 ↗
401

அங்கீகரிக்கப்படவில்லை

அங்கீகாரம் தேவை, ஆனால் வழங்கப்படவில்லை.

கிளையன்ட் அங்கீகார சான்றுகளை (Authorization header, cookie, token) சேர்க்க வேண்டும். 'Unauthorized' என்பது தவறான பெயர் — உண்மையில் 'unauthenticated' என்று பொருள்.

RFC 9110 ↗
402

கட்டணம் தேவை

எதிர்கால பயன்பாட்டிற்கு ஒதுக்கப்பட்டது — சில நேரங்களில் paid API tiers-க்குப் பயன்படுத்தப்படுகிறது.

முதலில் டிஜிட்டல் கட்டணங்களுக்காக நோக்கப்பட்டது. நவீன பயன்பாடு: ஒரு பயனர் தங்கள் paid quota-வைத் தாண்டிவிட்டால் APIகள் சில நேரங்களில் 402-ஐ திருப்பி அனுப்பும்.

RFC 9110 ↗
403

தடைசெய்யப்பட்டது

கிளையன்ட் அங்கீகரிக்கப்பட்டுள்ளது, ஆனால் அனுமதி இல்லை.

401-இலிருந்து வேறுபட்டது — பயனர் உள்நுழைந்திருக்கிறார், ஆனால் அவரது கணக்கிற்கு இந்த வளத்திற்கான அனுமதி இல்லை. role/permissions தர்க்கத்தைச் சரிபார்க்கவும்.

RFC 9110 ↗
404

கிடைக்கவில்லை

கோரப்பட்ட வளம் இல்லை.

URL தவறு, வளம் நீக்கப்பட்டது, அல்லது அது ஒருபோதும் இருந்ததில்லை. 403 சரியானதாக இருக்கும் என்பதை மறைக்க சேவையகங்கள் சில நேரங்களில் 404-ஐ திருப்பி அனுப்பும்.

RFC 9110 ↗
405

முறை அனுமதிக்கப்படவில்லை

இந்த வளத்திற்குப் பயன்படுத்தப்பட்ட HTTP முறை அனுமதிக்கப்படவில்லை.

எடுத்துக்காட்டாக, POST-ஐ மட்டுமே ஏற்கும் endpoint-க்கு GET கோரிக்கை. பதிலில் செல்லுபடியாகும் முறைகளைப் பட்டியலிடும் Allow header இருக்க வேண்டும்.

RFC 9110 ↗
406

ஏற்றுக்கொள்ள முடியாது

கிளையன்டின் Accept headers-உடன் எந்த பிரதிநிதித்துவமும் பொருந்தவில்லை.

கிளையன்ட் (Accept, Accept-Language, Accept-Encoding மூலம்) சேவையகத்தால் பூர்த்தி செய்ய முடியாத content type, மொழி அல்லது encoding-ஐக் கேட்டது. பல சேவையகங்கள் கடுமையான negotiation-ஐத் தவிர்த்து default-ஐத் திருப்பி அனுப்பும்.

RFC 9110 ↗
407

Proxy அங்கீகாரம் தேவை

கிளையன்ட் முதலில் proxy-உடன் அங்கீகரிக்க வேண்டும்.

401 போலவே, ஆனால் proxy மூலம் வழங்கப்படுகிறது: கிளையன்ட் Proxy-Authorization சான்றுகளை அனுப்ப வேண்டும். அங்கீகரிக்கும் proxies கொண்ட corporate networks-இல் காணப்படுகிறது.

RFC 9110 ↗
408

கோரிக்கை நேரம் முடிந்தது

கோரிக்கைக்காக காத்திருக்கும்போது சேவையகத்தின் நேரம் முடிந்தது.

கிளையன்ட் கோரிக்கை body-ஐ அனுப்ப அதிக நேரம் எடுத்தது அல்லது இணைப்பை idle-ஆக வைத்திருந்தது. கோரிக்கையை மீண்டும் முயற்சிக்கவும்.

RFC 9110 ↗
409

முரண்பாடு

கோரிக்கை வளத்தின் தற்போதைய நிலையுடன் முரண்படுகிறது.

பொதுவாக concurrent edit முரண்பாடுகளுக்கு அல்லது நகல் வளம் உருவாக்கத்திற்கு (எ.கா., ஏற்கனவே உள்ள மின்னஞ்சலுடன் பயனரை உருவாக்குதல்) திருப்பி அனுப்பப்படுகிறது.

RFC 9110 ↗
410

இல்லை

வளம் நீக்கப்பட்டது, மீண்டும் வராது.

404-ஐ விட வலிமையானது — வளம் முன்பு இருந்தது ஆனால் நிரந்தரமாக அகற்றப்பட்டது என்பது சேவையகத்திற்குத் தெளிவாகத் தெரியும். தேடுபொறிகள் அதை deindex செய்யும்.

RFC 9110 ↗
411

நீளம் தேவை

சேவையகத்திற்கு Content-Length header தேவை.

Content-Length header இல்லாததால் கோரிக்கை நிராகரிக்கப்பட்டது, சேவையகம் தெரியாத அளவிலான bodies-ஐ ஏற்காது. header-ஐச் சேர்த்து மீண்டும் முயற்சிக்கவும்.

RFC 9110 ↗
412

முன்நிபந்தனை தோல்வியடைந்தது

கோரிக்கை headers-இல் உள்ள ஒரு நிபந்தனை பூர்த்தி செய்யப்படவில்லை.

If-Match அல்லது If-Unmodified-Since போன்ற நிபந்தனை headers தோல்வியடையும் போது திருப்பி அனுப்பப்படுகிறது — பொதுவாக optimistic locking: உங்கள் பதிப்பிற்குப் பிறகு வேறு யாரோ வளத்தை மாற்றியுள்ளனர். மீண்டும் பெற்று முயற்சிக்கவும்.

RFC 9110 ↗
413

Payload மிகப் பெரியது

கோரிக்கை body சேவையகத்தின் அளவு வரம்பை மீறுகிறது.

பெரிய கோப்புகளை பதிவேற்றும்போது பொதுவாக ஏற்படும். சேவையக அமைவு (nginx, apache) அதிகபட்ச body அளவை நிர்ணயிக்கிறது. சேவையக அமைவுகளைச் சரிபார்க்கவும்.

RFC 9110 ↗
414

URI மிக நீளமானது

கோரிக்கை URL சேவையகத்தின் நீள வரம்பை மீறுகிறது.

பொதுவாக மிக நீண்ட query strings-ஆல் ஏற்படுகிறது (எ.கா. GET-இல் தரவை encode செய்தல்). POST body-க்கு மாறவும், அல்லது நீங்கள் கட்டுப்படுத்தினால் சேவையக வரம்பை உயர்த்தவும்.

RFC 9110 ↗
415

ஆதரிக்கப்படாத Media வகை

அனுப்பப்பட்ட Content-Type-ஐக் கையாள சேவையகத்தால் முடியவில்லை.

எடுத்துக்காட்டாக, application/json-ஐ மட்டுமே ஏற்கும் சேவையகத்திற்கு application/xml அனுப்புதல். Content-Type header-ஐச் சரியாக அமைக்கவும்.

RFC 9110 ↗
416

வரம்பு பூர்த்தி செய்ய முடியவில்லை

கோரப்பட்ட byte range வளத்தின் அளவிற்கு வெளியே உள்ளது.

Range header கோப்பில் இல்லாத ஒரு பகுதியைக் கேட்கிறது — எ.கா. கோப்பின் முடிவைத் தாண்டி பதிவிறக்கத்தை மீண்டும் தொடங்குதல். பதிலில் உண்மையான அளவுடன் Content-Range இருக்க வேண்டும்.

RFC 9110 ↗
417

எதிர்பார்ப்பு தோல்வியடைந்தது

Expect header-இன் தேவைகளை சேவையகத்தால் பூர்த்தி செய்ய முடியவில்லை.

சேவையகம் Expect: 100-continue-ஐ ஆதரிக்காதபோது அனுப்பப்படுகிறது. சில கிளையன்ட்கள் பெரிய POSTகளில் இந்த header-ஐ இயல்பாக அனுப்பும்; அதை முடக்குவது பொதுவாக பிழையைத் தீர்க்கும்.

RFC 9110 ↗
418

நான் ஒரு டீபாட்

தான் ஒரு டீபாட் என்பதால் காபி தயாரிக்க சேவையகம் மறுக்கிறது.

1998-இல் ஒரு ஏப்ரல் ஃபூல் ஜோக் (RFC 2324). சில உண்மையான APIகள் இதை நகைச்சுவைக்காக அல்லது deprecated endpoints-ஐக் குறிக்கப் பயன்படுத்துகின்றன. production-க்குப் பயன்படுத்த வேண்டாம்.

RFC 2324 ↗
421

தவறாக இயக்கப்பட்ட கோரிக்கை

இதற்கான பதிலைத் தயாரிக்க முடியாத சேவையகத்திற்கு கோரிக்கை அனுப்பப்பட்டது.

HTTP/2 connection reuse-இல் பொதுவானது: கோரிக்கை இலக்கு hostname-க்கு உள்ளமைக்கப்படாத சேவையகத்தை அடைந்தது. கிளையன்ட் புதிய இணைப்பில் மீண்டும் முயற்சிக்க வேண்டும்.

RFC 9110 ↗
422

செயலாக்க முடியாத உள்ளடக்கம்

கோரிக்கை syntax-படி சரியானது, ஆனால் பொருள்ரீதியாகத் தவறானது.

எடுத்துக்காட்டாக, JSON சரியாக parse ஆனது ஆனால் தேவையான புலம் விடுபட்டது, அல்லது ஒரு புல மதிப்பு வரம்பிற்கு வெளியே இருந்தது. REST API validation பதில்களில் பொதுவானது.

RFC 9110 ↗
423

பூட்டப்பட்டது

வளம் பூட்டப்பட்டுள்ளது.

WebDAV: மூல அல்லது இலக்கு வளம் வேறொரு கிளையன்டால் பூட்டப்பட்டுள்ளது, எனவே செயல்பாடு தொடர முடியாது. பூட்டு விடுவிக்கப்படும் வரை காத்திருக்கவும் அல்லது சரியான token-உடன் அதை உடைக்கவும்.

RFC 4918 ↗
424

சார்பு தோல்வியடைந்தது

முந்தைய சார்புடைய கோரிக்கை தோல்வியடைந்ததால் கோரிக்கை தோல்வியடைந்தது.

WebDAV: சார்புடைய செயல்பாடுகளின் சங்கிலியில், முந்தைய செயல் தோல்வியடைந்தது, எனவே இது செய்யப்படவில்லை. மூல காரணத்திற்கு முந்தைய தோல்வியைப் பார்க்கவும்.

RFC 4918 ↗
425

மிக விரைவானது

மீண்டும் இயக்கப்படக்கூடிய கோரிக்கையை செயலாக்க சேவையகம் மறுக்கிறது.

TLS 1.3 0-RTT (early data)-உடன் தொடர்புடையது: மீண்டும் இயக்கப்பட்ட கோரிக்கையை செயலாக்கும் அபாயத்தை சேவையகம் எடுக்காது. handshake முடிந்தபின் கிளையன்ட் மீண்டும் முயற்சிக்க வேண்டும்.

RFC 8470 ↗
426

மேம்படுத்தல் தேவை

கிளையன்ட் வேறு protocol-க்கு மாற வேண்டும்.

தற்போதைய protocol-இல் கோரிக்கைக்கு சேவை செய்ய சேவையகம் மறுக்கிறது, ஆனால் மேம்படுத்தலுக்குப் பிறகு செய்யும் — பதிலில் தேவையான protocol-ஐக் குறிக்கும் Upgrade header இருக்கும்.

RFC 9110 ↗
428

முன்நிபந்தனை தேவை

கோரிக்கை நிபந்தனைக்குட்பட்டதாக இருக்க வேண்டும் என்று சேவையகம் கோருகிறது.

lost-update முரண்பாடுகளைத் தடுக்க சேவையகம் நிபந்தனை headers-ஐ (If-Match போன்றவை) கோருகிறது. வளத்தைப் பெற்று, அதன் ETag-ஐப் பிடித்து, If-Match-உடன் மீண்டும் அனுப்பவும்.

RFC 6585 ↗
429

மிக அதிக கோரிக்கைகள்

கிளையன்ட் rate-limit செய்யப்பட்டுள்ளது.

வேகத்தைக் குறைக்கவும். மீண்டும் எப்போது முயற்சிக்க வேண்டும் என்பதைக் குறிக்கும் Retry-After header பதிலில் இருக்க வேண்டும். request quotas கொண்ட APIகளில் பொதுவானது.

RFC 6585 ↗
431

கோரிக்கை Header புலங்கள் மிகப் பெரியவை

சேவையகத்தால் செயலாக்க headers மிகப் பெரியவை.

ஒரு header அல்லது மொத்த header அளவு வரம்பை மீறுகிறது — பெரும்பாலும் அளவிற்கதிக cookies காரணமாக ஏற்படுகிறது. cookies-ஐ அழிக்கவும் அல்லது உங்கள் ஆப் அவற்றில் சேமிப்பதைக் குறைக்கவும்.

RFC 6585 ↗
451

சட்டரீதியான காரணங்களால் கிடைக்கவில்லை

சட்டரீதியான கோரிக்கைகள் காரணமாக அணுகல் மறுக்கப்பட்டது.

வளம் சட்டரீதியான காரணங்களுக்காக — தணிக்கை, நீதிமன்ற உத்தரவுகள் அல்லது பிராந்திய விதிமுறைகள் — தடுக்கப்பட்டுள்ளது. இந்த எண் Fahrenheit 451 நாவலுக்கு ஒரு குறிப்பு.

RFC 7725 ↗
500

உள் சேவையக பிழை

சேவையகத்தில் எதிர்பாராத நிலை ஏற்பட்டது.

சேவையக-தரப்பு பிழைகளுக்கான பொதுவான catch-all. உண்மையான காரணத்திற்கு சேவையக logs-ஐச் சரிபார்க்கவும்: கையாளப்படாத விதிவிலக்கு, database பிழை, முதலியன.

RFC 9110 ↗
501

செயல்படுத்தப்படவில்லை

கோரப்பட்ட செயல்பாட்டை சேவையகம் ஆதரிக்கவில்லை.

எடுத்துக்காட்டாக, சேவையகம் HTTP முறையை அடையாளம் காணவில்லை. நடைமுறையில் அரிது — பெரும்பாலும் 405-ஐக் காண்பீர்கள்.

RFC 9110 ↗
502

தவறான Gateway

gateway-ஆகச் செயல்படும் சேவையகம் upstream சேவையகத்திடமிருந்து தவறான பதிலைப் பெற்றது.

microservice கட்டமைப்புகளில் பொதுவானது. உங்கள் load balancer அல்லது reverse proxy backend சேவையிலிருந்து தவறான வடிவமைப்பு கொண்ட பதிலைப் பெற்றது.

RFC 9110 ↗
503

சேவை கிடைக்கவில்லை

கோரிக்கையைக் கையாள சேவையகத்தால் தற்காலிகமாக முடியவில்லை.

பராமரிப்புக்காக செயலிழக்க வைக்கப்பட்டது அல்லது ஓவர்லோட் ஆனது. பதிலில் Retry-After header இருக்க வேண்டும். deployments-இன் போது அடிக்கடி திருப்பி அனுப்பப்படுகிறது.

RFC 9110 ↗
504

Gateway நேரம் முடிந்தது

upstream பதிலுக்காக காத்திருக்கும்போது gateway சேவையகத்தின் நேரம் முடிந்தது.

backend சேவை போதுமான வேகத்தில் பதிலளிக்கவில்லை. upstream சேவை நிலை மற்றும் timeout அமைவுகளைச் சரிபார்க்கவும்.

RFC 9110 ↗
505

HTTP பதிப்பு ஆதரிக்கப்படவில்லை

கோரிக்கையில் பயன்படுத்தப்பட்ட HTTP பதிப்பை சேவையகம் ஆதரிக்கவில்லை.

கோரிக்கையின் முக்கிய HTTP பதிப்பை சேவையகம் ஆதரிக்கவில்லை. நவீன கிளையன்ட்களுடன் கிட்டத்தட்ட ஒருபோதும் காணப்படாது.

RFC 9110 ↗
506

Variant-உம் Negotiate செய்கிறது

சேவையகத்தில் content negotiation தவறான அமைவு உள்ளது.

Transparent content negotiation ஒரு சுழற்சியில் முடிந்தது: தேர்ந்தெடுக்கப்பட்ட variant தானும் negotiate செய்ய அமைக்கப்பட்டுள்ளது. சேவையக அமைவு பிழையைக் குறிக்கிறது.

RFC 2295 ↗
507

போதிய சேமிப்பகம் இல்லை

சேவையகத்தில் டிஸ்க் இடம் இல்லை.

தோற்றத்தில் WebDAV-க்கு உரியது ஆனால் சில நேரங்களில் பொது சேவையகங்களால் பயன்படுத்தப்படுகிறது. சேமிப்பக கட்டுப்பாடுகள் காரணமாக கோரிக்கையை சேவையகத்தால் சேமிக்க முடியவில்லை என்று பொருள்.

RFC 4918 ↗
508

சுழற்சி கண்டறியப்பட்டது

கோரிக்கையை செயலாக்கும்போது சேவையகம் ஒரு முடிவற்ற சுழற்சியைக் கண்டறிந்தது.

WebDAV: Depth: infinity கோரிக்கையை செயலாக்குவது ஒரு சுழற்சிக்குள் சென்றது (எ.கா. வட்டமான bindings). செயல்பாடு நிறுத்தப்பட்டது.

RFC 5842 ↗
510

நீட்டிக்கப்படவில்லை

கோரிக்கைக்கு மேலும் நீட்டிப்புகள் தேவை.

காலாவதியான HTTP Extension Framework-இலிருந்து: கோரிக்கையை நிறைவேற்றுவதற்கு முன் சேவையகத்திற்கு மேலும் தகவல் தேவை. நவீன வலையில் பயனுள்ள முறையில் பயன்படுத்தப்படவில்லை.

RFC 2774 ↗
511

பிணைய அங்கீகாரம் தேவை

பிணைய அணுகலைப் பெற கிளையன்ட் அங்கீகரிக்க வேண்டும்.

வெளிப்புற தளங்களை அணுகுவதற்கு முன் பயனர் பிணையத்தில் உள்நுழைய வேண்டும் என்பதைக் குறிக்க captive portals (ஹோட்டல்/விமான நிலைய WiFi) பயன்படுத்துகின்றன.

RFC 6585 ↗

இது எவ்வாறு செயல்படுகிறது

இந்தக் கருவி ஐந்து வகுப்புகளையும் (1xx–5xx) உள்ளடக்கிய 63 HTTP status codes இன் நிலையான தேடல் அட்டவணையைச் சுற்றி உருவாக்கப்பட்ட client-side குறிப்பு; ஒவ்வொன்றும் அதை வரையறுக்கும் RFC எண்ணுடன். சர்வர் அழைப்பு இல்லை, வெளி API இல்லை, நெட்வொர்க் கோரிக்கை இல்லை — அனைத்து வடிகட்டலும் காட்சியும் JavaScript இன் உள்ளமைந்த array, string முறைகள் மூலம் உலாவியில் நடக்கின்றன.

  1. 1
    தேடல் அட்டவணை ஏற்றப்படுகிறது
    IANA-பதிவுசெய்த 63 status codes இன் முழுத் தொகுப்பும் JavaScript array ஆக இந்தக் கருவியில் நேரடியாக உட்பொதிக்கப்பட்டுள்ளது; ஒவ்வொரு பதிவும் எண் code, நிலையான ஆங்கிலப் பெயர், வகை வகுப்பு, அதை வரையறுக்கும் குறிப்பிட்ட RFC ஆகியவற்றைக் கொண்டுள்ளது (எ.கா. பெரும்பாலான HTTP/1.1 codes க்கு RFC 9110, 429 Too Many Requests க்கு RFC 6585, 418 I'm a Teapot க்கு RFC 2324).
  2. 2
    வடிகட்டல் நினைவகத்தில் இயங்குகிறது
    நீங்கள் தட்டச்சு செய்யும்போது அல்லது வகை வடிகட்டியைத் தேர்ந்தெடுக்கும்போது, JavaScript இன் Array.filter நினைவகப் பட்டியலில் இயங்கி, உங்கள் தேடலை status code எண், நிலையான பெயர், குறுகிய மற்றும் நீண்ட விளக்க strings உடன் String.includes மூலம் பொருத்துகிறது — debounce தாமதம் இல்லை, சர்வர் பயணம் இல்லை.
  3. 3
    விவரங்கள் RFC இணைப்புடன் விரிகின்றன
    ஒவ்வொரு முடிவும் HTML details/summary உறுப்பாகக் காட்டப்படுகிறது. ஒரு பதிவை விரித்தால் நீண்ட விளக்கமும் rfc-editor.org இல் உள்ள அதிகாரப்பூர்வ RFC க்கான நேரடி இணைப்பும் தெரியும்; எனவே எந்த code க்கும் சரியான விவரக்குறிப்பு உரையைப் படிக்கலாம்.
  4. 4
    ஆழமான இணைப்புகள் மற்றும் கிளிப்போர்டு நகல்
    ஒரு பதிவைத் திறந்தால் URL hash code எண்ணுக்குப் புதுப்பிக்கப்படுகிறது (எ.கா. #404); பக்கத்தைப் பகிரவும் புக்மார்க் செய்யவும் எளிதாக்குகிறது. நகல் பொத்தான் நிலையான string ஐ (எ.கா. '404 Not Found') உலாவியின் navigator.clipboard API வழியாகக் கிளிப்போர்டில் எழுதுகிறது.

தொடர்புடைய கருவிகள்

அடிக்கடி கேட்கப்படும் கேள்விகள்